Bug #79433

Story #69617: FormEngine bugs

flux containers do not work anymore / type=array + section=1

Added by Christian Weiske over 2 years ago. Updated over 1 year ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-01-24
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The flux extension provides a "container" element that used to work in TYPO3 6.2 - see the screenshot at http://p.cweiske.de/234#2-form.png

Internally a flexform structure with the following settings is generated:

type    => array
section => 1
title   => blabla
el      => child elements

This does not work with TYPO3 7.6.10. In the flux bug report I opened, Claus Due asked me to ask here if this type of element should be supported by the form engine:

to clarify if this is supposed to be supported. If it is not, we should probably request that a specific exception be thrown in this case, since right now FormEngine allows the structure but cannot render it.

So please either fix this bug by re-introducing support for particular type of half-section, half-sectionobject or throw an exception stating that it's not supported.

History

#1 Updated by Christian Kuhn over 2 years ago

  • Parent task set to #69617

i can have a look at this after feature freeze of v8.6 in two weeks.

#2 Updated by Philipp Se├čner over 1 year ago

Christian Kuhn wrote:

i can have a look at this after feature freeze of v8.6 in two weeks.

This is still an issue in TYPO3 8.7. Any news on this?

Also available in: Atom PDF