Bug #80679

Input field eval datetime in FlexForm converts to wrong timestamp

Added by R3 H6 over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2017-04-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

A input field with eval datetime converts to a wrong timestamp.
After saving a form, the date will have a difference of 2 or 4 hours (Summertime).


Related issues

Related to TYPO3 Core - Bug #79557: Date fields DataMapper handling problemNew2017-01-30

Actions
Related to TYPO3 Core - Bug #79613: Saving wrong Date into DB if Field is of type DATENew2017-02-03

Actions
Related to TYPO3 Core - Bug #68651: Datetime() properties have wrong timezoneAcceptedAndreas Wolf2015-07-30

Actions
Is duplicate of TYPO3 Core - Bug #79249: TCA fields with eval types "time" or "timesec" are incorrectly stored in the databaseClosedMarkus Klein2017-01-10

Actions
#1

Updated by Mona Muzaffar over 4 years ago

  • Related to Bug #79957: TCA fields with eval types "time" or "timesec" decrease on every save added
#2

Updated by Mona Muzaffar over 4 years ago

  • Related to Bug #79557: Date fields DataMapper handling problem added
#3

Updated by Mona Muzaffar over 4 years ago

  • Related to Bug #79613: Saving wrong Date into DB if Field is of type DATE added
#4

Updated by Mona Muzaffar over 4 years ago

  • Related to Bug #68651: Datetime() properties have wrong timezone added
#5

Updated by Mona Muzaffar over 4 years ago

  • Related to Epic #80852: Datetime handling in backend added
#6

Updated by R3 H6 over 4 years ago

I like to be more precise.

Eval set to datetime seems to work fine in FlexForm.

The problem is if eval is set to time, then the time changes with every saving.

As far as I could see the difference between datetime and time is, that in DataHandler::checkValue_input_Eval $value is an timestamp for time (1494418260), and a date string for datetime (2017-05-10T14:11:00+00:00).
Maybe the problem is somewhere in a JavaScript.

#7

Updated by Markus Klein over 4 years ago

  • Status changed from New to Accepted
  • Parent task set to #77562
  • Is Regression changed from No to Yes
#8

Updated by Markus Klein over 4 years ago

  • Status changed from Accepted to Closed
  • Parent task deleted (#77562)

Same issue as #79957. Closing as duplicate.

#9

Updated by Markus Klein over 4 years ago

  • Related to deleted (Bug #79957: TCA fields with eval types "time" or "timesec" decrease on every save)
#10

Updated by Markus Klein over 4 years ago

  • Is duplicate of Bug #79957: TCA fields with eval types "time" or "timesec" decrease on every save added
#11

Updated by Markus Klein over 4 years ago

  • Related to deleted (Epic #80852: Datetime handling in backend)
#12

Updated by Markus Klein over 4 years ago

  • Is duplicate of Bug #79249: TCA fields with eval types "time" or "timesec" are incorrectly stored in the database added
#13

Updated by Markus Klein over 4 years ago

  • Is duplicate of deleted (Bug #79957: TCA fields with eval types "time" or "timesec" decrease on every save)

Also available in: Atom PDF