Bug #79957

TCA fields with eval types "time" or "timesec" decrease on every save

Added by Thomas Kieslich almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-02-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

A TCA Column with this config

'config' => [
            'type' => 'input',
            'size' => '12',
            'eval' => 'time',
            'default' => '0'
        ]

decrease on first save for 2 hours and on every next save for on hour.

Tested on Mamp Pro on osx with CET Timezone. Php date.timezone is Europe/Berlin.


Files


Related issues

Is duplicate of TYPO3 Core - Bug #79249: TCA fields with eval types "time" or "timesec" are incorrectly stored in the databaseClosedMarkus Klein2017-01-10

Actions
#1

Updated by Markus Sommer over 4 years ago

Hallo,

The Problem is reproducible with ext:styleguide

Tested with the "elements basic"

After each save the value reduced by 1 to 4 hours.
This behavior is only by the "inputdatetime_5 eval=time" and the "inputdatetime_6 eval=timesec" field.

I think it commes from the timepicker.

#2

Updated by Markus Sommer over 4 years ago

  • Sprint Focus set to Stabilization Sprint
#3

Updated by Christian Kuhn over 4 years ago

  • Target version deleted (8 LTS)
  • Sprint Focus deleted (Stabilization Sprint)
#4

Updated by Mona Muzaffar over 4 years ago

  • Related to Bug #80679: Input field eval datetime in FlexForm converts to wrong timestamp added
#5

Updated by Mona Muzaffar over 4 years ago

  • Related to Epic #80852: Datetime handling in backend added
#6

Updated by Alex Kellner over 4 years ago

This is still a critical thing in my eyes. Records with time fields are not usable since 8.6 any more :/

#8

Updated by Markus Klein over 4 years ago

  • Status changed from New to Accepted
  • Parent task set to #77562
#9

Updated by Markus Klein over 4 years ago

  • Related to deleted (Bug #80679: Input field eval datetime in FlexForm converts to wrong timestamp)
#10

Updated by Markus Klein over 4 years ago

  • Has duplicate Bug #80679: Input field eval datetime in FlexForm converts to wrong timestamp added
#11

Updated by Riccardo De Contardi over 4 years ago

  • Related to deleted (Epic #80852: Datetime handling in backend)
#12

Updated by Markus Klein over 4 years ago

  • Status changed from Accepted to Closed

This solved with #79249.
Will mark this one as duplicate an close.

#13

Updated by Markus Klein over 4 years ago

  • Is duplicate of Bug #79249: TCA fields with eval types "time" or "timesec" are incorrectly stored in the database added
#14

Updated by Markus Klein over 4 years ago

  • Has duplicate deleted (Bug #80679: Input field eval datetime in FlexForm converts to wrong timestamp)
#15

Updated by Markus Klein over 4 years ago

  • Parent task deleted (#77562)

Also available in: Atom PDF