Bug #80802

ImageCropping control buttons not displayed

Added by David Rellstab about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2017-04-11
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
JavaScript, CSS
Complexity:
medium
Is Regression:
Sprint Focus:

Description

When cropping an image with a height that is too big for the cropping dialog in certain browsers the control buttons (accept & cancel) disappear (see Screenshot 1).

This behaviour is reproducable on a fresh TYPO3 8.7.0 distribution with the following browsers:
Firefox 52.0.2
Microsoft Edge 38.14393.0.0

The problem seems to be that the image is not resized to fit the dialog size in those two browsers.

The image used to reproduce is also attached.

Beispielbild_Hochformat1.jpg View - Image to reproduce the bug (201 KB) David Rellstab, 2017-04-11 10:07

ImageCropping_Missing_ControlButtons.PNG View - There are no control buttons at the bottom (1020 KB) David Rellstab, 2017-04-11 10:07


Related issues

Related to TYPO3 Core - Bug #81387: Modal window is cut if content is extra large Closed 2017-05-31
Duplicates TYPO3 Core - Bug #80937: Image Manipulation: Saving not possible when image is bigger than screen. Closed 2017-04-21
Duplicates TYPO3 Core - Bug #81062: Image Cropping could not be saved in Firefox Closed 2017-04-28
Duplicated by TYPO3 Core - Bug #81626: Buttons in image manipulation wizard not reachable with large protrait image Closed 2017-06-20

History

#1 Updated by Angelo Previtali about 3 years ago

I can confirm this confirm this bug with TYPO3 version 8.7.0.

#2 Updated by Mona Muzaffar about 3 years ago

  • Duplicates Bug #80937: Image Manipulation: Saving not possible when image is bigger than screen. added

#3 Updated by Mona Muzaffar about 3 years ago

  • Duplicates Bug #81062: Image Cropping could not be saved in Firefox added

#4 Updated by Mona Muzaffar about 3 years ago

  • Status changed from New to Closed

#5 Updated by Mona Muzaffar about 3 years ago

  • Status changed from Closed to New

#6 Updated by Benjamin Kott almost 3 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Sprint Focus set to Remote Sprint

#7 Updated by Benjamin Kott almost 3 years ago

  • Sprint Focus changed from Remote Sprint to On Location Sprint

#8 Updated by Oliver Hader almost 3 years ago

  • Tags set to JavaScript

#9 Updated by Jasmina LieƟmann almost 3 years ago

  • Related to Bug #81387: Modal window is cut if content is extra large added

#10 Updated by Mona Muzaffar almost 3 years ago

  • Duplicated by Bug #81626: Buttons in image manipulation wizard not reachable with large protrait image added

#11 Updated by Susanne Moog almost 3 years ago

  • Complexity set to medium

#12 Updated by Susanne Moog almost 3 years ago

  • Tags changed from JavaScript to JavaScript, CSS

#13 Updated by Anja Leichsenring over 2 years ago

  • Sprint Focus deleted (On Location Sprint)

#14 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Accepted to Needs Feedback

It seems already solved for TYPO3 8.7.9, could you confirm? I tested with Chrome and Firefox on MAC.

Thank you!

#15 Updated by Klaus Moser over 2 years ago

Just tested with Typo3 8.7.8 in FF and IE 11 and this issue seems to be solved even in this version.

#16 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed

@Klaus Moser thank you for testing on IE too.

I think it is safe to close this issue for now; if you think that this is the wrong decision or experience the issue again please reopen it or open a new issue with a reference to this one and details about how to reproduce it. Thank you.

Also available in: Atom PDF