Project

General

Profile

Actions

Bug #81118

closed

extbase classmap entry breaks composer create-project

Added by Anja Leichsenring almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
composer
Target version:
Start date:
2017-05-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

when setting up a project composer based with

composer create-project typo3/cms cms ^8.7 -n

the command failes with

...
Generating autoload files

  [RuntimeException]
  Could not scan for classes inside "typo3/sysext/extbase/Tests/Unit/Object/Container/Fixtures/" which does not appear to
  be a file nor a folder

This happens for the classmap entry in sysext:extbase/composer.jons line 41, that tries to load Test classes into autoload-dev autoloading. But thanks to Testclasses being excluded from the operation (git attributes I guess) the folder does not exist and the command fails.

One can work around that by adding --prefer-source to the create-project command, but that slows down the whole process a lot and ends up with all test classes in place.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #77545: composer autoload fails because of sysext extbaseClosed2016-08-19

Actions
Actions #1

Updated by Anja Leichsenring almost 7 years ago

  • Description updated (diff)
Actions #2

Updated by Peter Foerger almost 7 years ago

  • Related to Bug #77545: composer autoload fails because of sysext extbase added
Actions #3

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #4

Updated by Wouter Wolters almost 7 years ago

  • Status changed from New to Closed

I'll close this one as a duplicate of #77545
Please continue in #77545

Actions

Also available in: Atom PDF