Project

General

Profile

Actions

Bug #77545

closed

composer autoload fails because of sysext extbase

Added by Sebastian Hofer almost 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-08-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the TYPO3 version 7.6.10 the sysext extbase causes an autoload error in composer:

"Could not scan for classes inside "typo3/sysext/extbase/Tests/Unit/Object/Container/Fixtures/" which does not appear to be a file nor a folder"

The whole "Tests" folder is missing in the extbase extension, so the autoload fails. With TYPO3 version 7.6.9 everything is fine.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #81118: extbase classmap entry breaks composer create-projectClosed2017-05-02

Actions
Actions #1

Updated by Wouter Wolters over 7 years ago

  • Status changed from New to Needs Feedback

Are you using this installation for testing purposes or is it for production?

If this is for production you can remove these lines in your root composer file.
The fixtures are only needed when you want to run the extbase Unit tests.

Actions #2

Updated by Nils Heuermann over 7 years ago

I have the same issue. I installed a Typo3 instance using following composer.json (just the relevant parts):

{
    "name": "my/typo3-install",
    "repositories": [
        {
            "type": "composer",
            "url": "https://composer.typo3.org/" 
        }
    ],
    "require": {
        "typo3/cms": "~7.6" 
    },
    "require-dev": {
        "phpunit/phpunit": "^5.5" 
    },
    "autoload-dev": {
        "psr-4": {
            "TYPO3\\CMS\\Core\\Tests\\": "typo3/sysext/core/Tests/",
            "TYPO3\\CMS\\Extbase\\Tests\\": "typo3/sysext/extbase/Tests/" 
        },
        "classmap": ["typo3/sysext/extbase/Tests/Unit/Object/Container/Fixtures/"]
    }
}

I wanted to add some unit tests to my extension but as said by Sebastian the "Tests" folder of extbase (typo3/sysext/extbase/Tests/) simply does not exist.
Is it intentionally excluded from the Typo3 composer package?

Actions #3

Updated by Sebastian Hofer over 7 years ago

With removing the line

"classmap": ["typo3/sysext/extbase/Tests/Unit/Object/Container/Fixtures/"]

It works for me.

Actions #4

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
Actions #5

Updated by Peter Foerger about 7 years ago

  • Related to Bug #81118: extbase classmap entry breaks composer create-project added
Actions #6

Updated by Helmut Hummel about 7 years ago

  • Status changed from New to Needs Feedback

Since this is an error in the root composer setup, this can be closed, right?

Actions #7

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please reopen it or open a new ticket and add a relation to this ticket number. Thank you!

Actions #8

Updated by David Bruchmann about 6 years ago

I still experience the error with 7.6.26:

    composer create-project typo3/cms typo3-7 ^7

but as Anja described in #81118 the parameter --prefer-source avoids the situation where the error is raised.

Actions

Also available in: Atom PDF