Project

General

Profile

Actions

Bug #81160

closed

Major problem with config.sendCacheHeaders

Added by Aimeos no-lastname-given almost 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Caching
Target version:
Start date:
2017-05-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Hi all

We've discovered a major problem in TYPO3 standard installations (all versions) due to a wrong interpretation of "Cache-Control: private": https://docs.typo3.org/typo3cms/TyposcriptReference/Setup/Config/#sendcacheheaders

Contrary to the documentation, "Cache-Control: private" does NOT tell the browser to avoid caching! Instead, it says "browsers can cache the page but proxies should not" (https://developers.google.com/web/fundamentals/performance/optimizing-content-efficiency/http-caching#public_vs_private)

This leads to situations where browsers show old content to users. There are even situations where requests never hit the server, like orders in online shops not being created in the database. The correct default setting to avoid that must be "Cache-Control: no-store"

Actions

Also available in: Atom PDF