Bug #81417

Record preview leads to error &cHash empty

Added by Rainer Becker over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-06-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The TCEMAIN.preview setting generates a link without chash so the opened page throws an error (&cHash empty)

Configuration:

TCEMAIN.preview {
    tx_news_domain_model_news {
        previewPageId = 98
        useDefaultLanguageRecord = 0
        fieldToParameterMap {
            uid = tx_news_pi1[news]
        }
        additionalGetParameters {
            tx_news_pi1.controller = News
            tx_news_pi1.action = detail
        }
    }
}


Related issues

Is duplicate of TYPO3 Core - Bug #78336: Avoid usage of no_cache in preview link configurationClosed2016-10-18

Actions
#1

Updated by Georg Ringer over 4 years ago

  • Is duplicate of Bug #78336: Avoid usage of no_cache in preview link configuration added
#2

Updated by Georg Ringer over 4 years ago

closing it as duplicate of #78336

see https://review.typo3.org/#/c/50264/ for a patch, would be great if you could test that.

#3

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF