Bug #81563

Story #69712: Further FormEngine development

TCA: Palettes in "subtypes_addlist" are not processed

Added by Jacob Dreesen over 2 years ago. Updated 10 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
-
Start date:
2017-06-13
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm using `subtypes_addlist` to show additional fields for certain subtypes.

This works fine except if I try to use palettes there. They seem to be ignored and don't show up in the backend.

Interestingly, an exception to this is when the same field is shown elsewhere in the type's `showitem`. In this case the field will be shown in the regular `showitem` and in the subtype palette (which is generally not desired).

History

#1 Updated by Christian Kuhn over 2 years ago

  • Parent task set to #69712

#2 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53267

#3 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53269

#4 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53269

#5 Updated by Benni Mack 10 months ago

  • Status changed from Under Review to New

Also available in: Atom PDF