Project

General

Profile

Actions

Bug #81729

closed

DateTimePicker not opening in IE/Edge

Added by Matthias Koch about 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
Start date:
2017-06-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

After an update of 8.7.1 to 8.7.2 the date/time selector popup doesn't open anymore.
Tested on 2 installations. All caches cleared and typo3temp deleted.

JS error says:
SCRIPT5007: Unable to get property 'top' of undefined or null reference
DateTimePicker.js (29,4)


Files

ie11-datetimepicker.png (44.8 KB) ie11-datetimepicker.png Wittkiel Gruppe, 2017-06-29 08:14
Actions #1

Updated by Wittkiel Gruppe about 7 years ago

Same problem here in IE11

Actions #2

Updated by Angelo Previtali about 7 years ago

I can confirm this issue on a 8.7.3, too. The datepicket in the whole TYPO3 8.7.3 is not working.

Actions #3

Updated by Thorben Nissen almost 7 years ago

  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel

Got the same error reported. Changed this to "must have", because this is really annoying.

Actions #4

Updated by Xavier Perseguers almost 7 years ago

  • Status changed from New to Accepted
Actions #5

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53573

Actions #6

Updated by Matthias Koch almost 7 years ago

Gerrit Code Review wrote:

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53573

Can confirm that the patch works on win10 in Edge and IE.

Actions #7

Updated by Xavier Perseguers almost 7 years ago

  • Assignee set to Xavier Perseguers

@Matthias thanks for reviewing but you should do that on https://review.typo3.org and give +1 on "verify" then, your vote here does not count as a good one for actually merging the fix.

Actions #8

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53583

Actions #9

Updated by Anonymous almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF