Bug #81890

Don't show cut and cut release at the same time in clickmenu

Added by Christian Fries about 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend JavaScript
Target version:
Start date:
2017-07-16
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I click on cut in the clickmenu and open the clickmenu for the same record again, both options cut and cut release are available. Cut shouldn't be available anymore.

Schermata 2017-07-17 alle 00.12.59.png View (43 KB) Riccardo De Contardi, 2017-07-17 00:15


Related issues

Duplicates TYPO3 Core - Bug #81875: Wrong label for cut release in clickmenu Closed 2017-07-14

Associated revisions

Revision 7f9c183c (diff)
Added by Frank Naegler over 1 year ago

[BUGFIX] Don't show “cut” and “cut release” at the same time

This patchs prevents showing “cut” and “cut release” at the same time in
the clickmenu of the page tree.

Resolves: #81890
Releases: master, 8.7
Change-Id: Ibfc07efec0f2064ffc9885047fce246cd935d368
Reviewed-on: https://review.typo3.org/54732
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

Revision b5c25e9d (diff)
Added by Frank Naegler over 1 year ago

[BUGFIX] Don't show “cut” and “cut release” at the same time

This patchs prevents showing “cut” and “cut release” at the same time in
the clickmenu of the page tree.

Resolves: #81890
Releases: master, 8.7
Change-Id: Ibfc07efec0f2064ffc9885047fce246cd935d368
Reviewed-on: https://review.typo3.org/54733
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Tested-by: TYPO3com <>

History

#1 Updated by Georg Ringer about 2 years ago

  • Status changed from New to Closed

this has been fixed during coding night of T3DD. See #81875

#2 Updated by Georg Ringer about 2 years ago

  • Duplicates Bug #81875: Wrong label for cut release in clickmenu added

#3 Updated by Riccardo De Contardi about 2 years ago

@Georg Ringer I think this is not a duplicate. We are talking of the presence of the "cut" icon when you have already cut the object - see the attached screenshot.
This happens only with pages AFAIK.

If you think that I am wrong or the behavior is intended, please close again.

#4 Updated by Riccardo De Contardi almost 2 years ago

  • Category set to Backend JavaScript

#5 Updated by Frank Naegler over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Frank Naegler
  • Target version set to 9.0

#6 Updated by Gerrit Code Review over 1 year ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54732

#7 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54732

#8 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54732

#9 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54733

#10 Updated by Frank Naegler over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Gerrit Code Review over 1 year ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54733

#12 Updated by Frank Naegler over 1 year ago

  • Status changed from Under Review to Resolved

#13 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF