Bug #81896

Drag and drop Text does not work

Added by Gernot Ploiner over 3 years ago. Updated 11 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-07-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There is a problem, if you mark text and move it with the mouse into the input field (drag and drop). Have a look at the attached screenshot.
The text get lost after saving.


Files

screen01.jpg (77 KB) screen01.jpg Gernot Ploiner, 2017-07-17 14:39
#1

Updated by Mona Muzaffar over 3 years ago

  • Status changed from New to Needs Feedback

I don't think drag and drop is even meant to be possible in this use case.
The gray field which you marked in your screenshot is only visible in translated elements and shows the value of the original/default element.
So it is only meant to be a help for editors when translating elements.

Correct me if i am wrong or misunderstood your use case.

#2

Updated by Gernot Ploiner over 3 years ago

Use case: You have the same word in your translation, because "Baby" is the same in english and in german. Also if you take a link value from the default translation or many cases more...

Then your browser supports the easy way to doubleclick the original words (text), then drag and drop it into the inputfield. Now TYPO3 lost the text after saving.

The TYPO3-working way is: Doubleclick the word, move your hand from the mouse to the keyboard, press crtl-c, move your hand to the mouse, click into the inputfield, move your hand back to the keyboard, press ctrl-v.

I know, this is not a major bug, but it is not the default browser behavior and it's confusing when the content is getting lost after saving.

#3

Updated by Riccardo De Contardi over 3 years ago

I was actually able to perform this kind of "maneuver" with the latest 9.0 master, and using the header field of a content element.

I suspect that the failed saving could be related to the recently solved problem of not saved content in Chrome due to backend javascript.

It seems not possible to do the same thing with the page fields.

#4

Updated by Mona Muzaffar over 3 years ago

  • Status changed from Needs Feedback to New
#5

Updated by Christian Eßl about 1 year ago

  • Category set to FormEngine aka TCEforms
#6

Updated by Susanne Moog 11 months ago

  • Status changed from New to Rejected

There is no real consistency of this behaviour on the web. For example redmine (this web site) and jira both do not support that drag and drop behaviour either while other web sites do. I also did not find a definition for how this should behave, therefor I don't consider it as a bug and will close the issue. Feel free to reopen the issue if there is a definition for that.

Also available in: Atom PDF