Bug #82116

Linkhandler doesn't build links when using registerPageTSConfigFile

Added by Thomas Deuling about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2017-08-16
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,
we're trying to provide a news Linkhandler like in this tutorial: https://usetypo3.com/linkhandler.html

But when we're inserting the tsconfig by using the following script in `Configuration/TCA/Overrides/pages.php`:

```
\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::registerPageTSConfigFile(
'theme_paperclip',
'Configuration/PageTS/Linkhandler/tx_news_news_typo3-8.typoscript',
'Linkhandler configuration for News (TYPO3 8.7)'
);
```

..the link in frontend isn't rendered. The news-link in backend is selectable in RTE and everything else works fine.

When we paste the content of the `Configuration/PageTS/Linkhandler/tx_news_news_typo3-8.typoscript` directly into the tsconfig field of our root page, the link is rendered in frontend.
So, it seems that `registerPageTSConfigFile` doesn't provide always the contained ts config.


Related issues

Duplicates TYPO3 Core - Bug #82293: Centralize getPagesTSconfig methods Closed 2017-09-05

History

#1 Updated by Riccardo De Contardi about 2 years ago

  • Category set to Link Handling, Site Handling & Routing

#2 Updated by Georg Ringer almost 2 years ago

  • Duplicates Bug #82293: Centralize getPagesTSconfig methods added

#3 Updated by Georg Ringer almost 2 years ago

  • Status changed from New to Closed

I am closing this because of #82293 which describes the problem a bit better.

#4 Updated by Karsten Nowak (undkonsorten) almost 2 years ago

I can confirm this.

If I use the registerPageTSConfigFile it doesn't work.

My workaround:
It works with the method "addPageTSConfig" and loading the file with the <INDLUDE> command.

Also available in: Atom PDF