Bug #82374

typo3 8.7.6 and 8.7.6 Problem with tag's in the CKeditor Table

Added by ger mai about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2017-09-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

n both versions 8.7.5 and also 8.7.6 is the problem. when we open an article and it contains a table element, we destroyed this article after saving it.
the sequence is, all tags are no longer written and all html code is output at the frontend. in the source code there are only nch doe <p> tags and all others are not included.

This is no matter whether you change something at the table or in the surrounding text. all contents will be destroyed when re-storing.

After resetting to version 8.7.4, everything works normally. Destroyed items are destroyed.

Thanks germai


Files

#1

Updated by Michael Stucki about 4 years ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Category deleted (Support)
  • TYPO3 Version set to 8

Move to correct project.

#2

Updated by Wouter Wolters about 4 years ago

  • Status changed from New to Needs Feedback

CKeditor version in 8.7.6 is the same as in 8.7.4, in 8.7.5 an update was done but got reverted in the latest 8 version. Are you sure this is still a problem on 8.7.6 or could it be a browser caching issue?

#3

Updated by ger mai about 4 years ago

I do not assume it can be the browser cache. First I have seen the problem with a customer installation which was on the stand 8.7.5. Our development system for the customer still had version 8.7.4. We had no problems. Then I have the latest version. In the GIT I found no 8.7.5 version. We have played 8.7.6 on our development system. This was the same behavior as under the live system with 8.7.5.
After changing our development system back to 8.7.4 again works fine. The live system under 8.7.4 also works perfectly.

#4

Updated by Riccardo De Contardi about 4 years ago

I am currently not able to reproduce it with 8.7.6

#5

Updated by ger mai about 4 years ago

I have try it on a new Installation of instructor pack in the picture first table with 8.7.6 and second 8.7.4.
I can reproduce it on all Installation i test it .

#6

Updated by Riccardo De Contardi about 4 years ago

Pardon me for my question, but what is the "instructor pack"?

I also wonder where does the class="info" comes from...

#7

Updated by ger mai about 4 years ago

sorry it wars a typo "The official Introduction Package" it is a base system. I put a class to the tr Element. it is only a test.

#8

Updated by Riccardo De Contardi about 4 years ago

I tried with a system with bootstrap_package installed, but still not able to reproduce it.

#9

Updated by ger mai about 4 years ago

we must verify this again.
Yes with the with bootstrap_package fun ktioniert it.

#10

Updated by ger mai about 4 years ago

in fact, we can trace this to 95% of all installations. Only absconded minimal systems do not show the problem so. Since it works with 8.7.4 tadelos, I can only assume that it has to do with the core changes.

#11

Updated by Grégory Duchesnes about 4 years ago

Seems to be related to #82476.

i can confirm weird behavior on CKeditor (removes p and span classes) after a direct upgrade from 8.7.4 to 8.7.6 so there is no 8.7.5 cache problem involved.

Furthermore a simple downgrade to 8.7.4 solves the problem without need to clear the browser cache. Therefore it does not seem to be a JS problem.

My feeling is that some default settings changed in typo3_src-8.7.6/typo3/sysext/core/Classes/Configuration/Richtext.php

#12

Updated by Grégory Duchesnes about 4 years ago

I found the origin of the problem, the bugfix "[BUGFIX] Allow to override RTE config via PageTS" changed the order of override for PageTS vs YAML RTE configuration therefore you could have a buggy line in your TSConfig it was fixed by the YAML configuration.
Now that this order has changed your TS might need some cleanup, in my case i add an absolete RTE.default.proc.allowedClasses value which broke my RTE in 8.7.6.

This is not a bug but should be mentionned as a breaking change

#13

Updated by Riccardo De Contardi about 4 years ago

maybe it has been solved with https://forge.typo3.org/issues/81381 ?

#14

Updated by Wouter Wolters over 3 years ago

  • Status changed from Needs Feedback to Closed

This was not related to the ckeditor update but as mentioned here another patch introduced another order of importing the configuration files. This change was not marked as breaking but should have been marked as breaking change. Closing this as solved.

Also available in: Atom PDF