Bug #82463

EXT:lang - erroneous date format after updating a single language

Added by RVVN no-lastname-given 10 months ago. Updated 3 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Language Manager (backend)
Target version:
-
Start date:
2017-09-12
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

The language manager displays an erroneous date format after updating a single language (see attachment).

Refreshing the frame display the correct formatted date.

lang_erroneous_lastUpdate_format.png View (9.11 KB) RVVN no-lastname-given, 2017-09-12 14:52

lang_erroneous_lastUpdate_format-8.7.12.png View (6.99 KB) RVVN no-lastname-given, 2018-03-23 11:01

cattura.png View (13.8 KB) Riccardo De Contardi, 2018-04-13 16:19

History

#1 Updated by Riccardo De Contardi 4 months ago

  • Status changed from New to Needs Feedback

Is this one still reproducible? I just tried to download again a language (Italian) and the "Last Update" date automatically updated itself without any weird effect. TYPO3 version used: 8.7.11

Do you have more information about how to reproduce it? Thank you!

#2 Updated by RVVN no-lastname-given 4 months ago

Hi,

unfortunately nothing changed after 8.7.12 update :/ (please see attachment).

#3 Updated by Riccardo De Contardi 4 months ago

I also tried again with 8.7.12 and I was still not able to reproduce this problem; this is my procedure:

1) Go to Languages Module
2) Look for "Italian"
3) click on download button and wait.

Are you using a different procedure?

Please could you also add more information about your environment? Have you configured your backend with a different language?

I am using the default language; My environment is MAMP on MAC with PHP 7.1.12

#4 Updated by RVVN no-lastname-given 3 months ago

I also use this procedure, for the French language.
The error still occurs : only the month value is correct, day and year markers are not replaced.

We have configured the backend with this language.

Here's our environment :

TYPO3 8.7.12
UBUNTU 16.04
NGINX 1.10.3
PHP-FPM 7.0

Is there anything you want/need to know about our environment ?

#5 Updated by Riccardo De Contardi 3 months ago

OK so the issue is visible only when you set the backend language in french.

That's not an environment problem, but just a translation problem :) I was able to find that the string with the date is replaced via Javascript in the cell and is taken from EXT:lang/Resources/Private/Language/locallang.xlf:table.dateFormat

<trans-unit id="table.dateFormat">
   <source>YYYY-MM-DD HH:mm</source>
</trans-unit>

Searching on the french version on https://translation.typo3.org/fr/TYPO3.core.lang/translate/#search=table.dateFormat&sfields=source,target,locations
this is what I see

I guess that it should simply be replaced with

DD.MM.YYYY, HH:mm

#6 Updated by RVVN no-lastname-given 3 months ago

Hi Riccardo, thanks for taking a look at this problem ;)

I'd like to contribute to translation but since I did it a few months ago (for extensionmanager extension here : https://translation.typo3.org/fr/TYPO3.core.extensionmanager/translate/locallang.1415814818.xlf#filter=suggestions), my suggestion is still pending.

What is the way to have translations approved "faster" ?

Also available in: Atom PDF