Bug #82501

Introduction package broken using PostgreSQL

Added by Stephan Großberndt over 2 years ago. Updated 2 months ago.

Status:
Needs Feedback
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2017-09-18
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After installing the introduction package on a TYPO3 8.7.6 and a PostgreSQL database and opening the first frontend page an exception in thrown due to an SQL error:

An exception occurred while executing 'SELECT * FROM "tt_content" WHERE ("tt_content"."pid" IN (2)) AND (=3) AND (("tt_content"."sys_language_uid" IN (0, -1)) OR (("l18n_parent" = 0) AND ("tt_content"."sys_language_uid" = 0))) AND (("tt_content"."deleted" = 0) AND ("tt_content"."t3ver_state" <= 0) AND ("tt_content"."pid" <> -1) AND ("tt_content"."hidden" = 0) AND ("tt_content"."starttime" <= 1505734620) AND (("tt_content"."endtime" = 0) OR ("tt_content"."endtime" > 1505734620)) AND ((("tt_content"."fe_group" = '') OR ("tt_content"."fe_group" IS NULL) OR ("tt_content"."fe_group" = '0') OR ('0' = ANY(string_to_array("tt_content"."fe_group"::text, ','))) OR ('-1' = ANY(string_to_array("tt_content"."fe_group"::text, ',')))))) ORDER BY "sorting" ASC': SQLSTATE[42601]: Syntax error: 7 FEHLER: Syntaxfehler bei »=« LINE 1: ...t_content" WHERE ("tt_content"."pid" IN (2)) AND (=3) AND ((... ^

Problem is a syntax error in the SQL query of TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer::exec_getQuery("tt_content", array): SELECT * FROM "tt_content" WHERE ("tt_content"."pid" IN (2)) AND (=3) where a wrong SQL condition AND (=3) is used.


Related issues

Related to TYPO3 Core - Epic #90719: PostgreSQL related issues Accepted 2020-03-10

History

#1 Updated by Stephan Großberndt over 2 years ago

  • Description updated (diff)

#2 Updated by Christian Kuhn over 2 years ago

weird. we have an acceptance test for exactly that: install system on postgres, load introduction package and verify frontend comes up.

#3 Updated by Tymoteusz Motylewski almost 2 years ago

  • Status changed from New to Closed

@Stephan, please reopen the issue if it's still failing for you with newest TYPO3.
Then please provide more info like postgres version, introduction package version and so.

#4 Updated by Stephan Großberndt over 1 year ago

  • Status changed from Closed to Needs Feedback

The acceptance tests do not log or care for sql errors. This is a general problem. The acceptance test still finds its buttons because it does not use the view where the error occurs. I will test whether its still an issue, but I bet it is.

#5 Updated by Christian Eßl 3 months ago

  • Related to Epic #90719: PostgreSQL related issues added

#6 Updated by Manuel Selbach 2 months ago

@Stephan Großberndt Do you have more information about that issue?

I tried it as it's described in the current master and was not able to reproduce the error.
I'm using PostgreSQL 9.6.16, with latest master of TYPO3 and PHP 7.2.19.

Is it still present in version 9.5?

Also available in: Atom PDF