Bug #82662

TSFE getPagesTSconfig does not use included registered page TSconfig

Added by Jigal van Hemert over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2017-10-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Registered Page TSconfig files can be included in arbitrary pages by selecting the items in the field "Include Page TSConfig (from extensions):". In the function \TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController::getPagesTSconfig() these includes are not taken into consideration.
In the corresponding BE function \TYPO3\CMS\Backend\Utility\BackendUtility::getPagesTSconfig() the includes are included.

If you include a registered TSconfig file with linkhandler configuration the new tab appears in the backend, but the link won't be rendered in the frontend because the TSconfig is missing.


Related issues

Related to TYPO3 Core - Bug #84116: Linkhandler links not rendered in frontend when TSConfig configuration is applied using "registerPageTSConfigFile()" or "addPageTSConfig()"Closed2018-03-02

Actions
Related to TYPO3 Core - Bug #81247: DatabaseRecordLinkBuilder: External pageTs not loadedClosed2017-05-17

Actions
#1

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54276

#2

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54276

#3

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54276

#4

Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54680

#5

Updated by Jigal van Hemert about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Georg Ringer almost 3 years ago

  • Related to Bug #84116: Linkhandler links not rendered in frontend when TSConfig configuration is applied using "registerPageTSConfigFile()" or "addPageTSConfig()" added
#7

Updated by Robert Vock almost 3 years ago

  • Related to Bug #81247: DatabaseRecordLinkBuilder: External pageTs not loaded added
#8

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF