Project

General

Profile

Actions

Bug #83311

closed

Not able to open de BE Web -> Forms module

Added by Frans Saris about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Category:
Form Framework
Target version:
-
Start date:
2017-12-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When running in development context you are not able to open de Web -> Forms module due to a php error:

Argument 1 passed to TYPO3\CMS\Form\Controller\AbstractBackendController::resolveResourcePaths() must be of the type array, null given, called in vendor/typo3/cms/typo3/sysext/form/Classes/Controller/FormManagerController.php on line 63

TypeError thrown in file
vendor/typo3/cms/typo3/sysext/form/Classes/Controller/AbstractBackendController.php in line 76.

15 TYPO3\CMS\Form\Controller\AbstractBackendController::resolveResourcePaths(NULL)

vendor/typo3/cms/typo3/sysext/form/Classes/Controller/FormManagerController.php:
00061: 
00062:         $this->view->assign('forms', $this->getAvailableFormDefinitions());
00063:         $this->view->assign('stylesheets', $this->resolveResourcePaths($this->formSettings['formManager']['stylesheets']));
00064:         $this->view->assign('dynamicRequireJsModules', $this->formSettings['formManager']['dynamicRequireJsModules']);
00065:         $this->view->assign('formManagerAppInitialData', $this->getFormManagerAppInitialData());

Actions #1

Updated by Frans Saris about 5 years ago

  • Description updated (diff)
Actions #2

Updated by Mario Rimann about 5 years ago

We've encountered the same issue, starting with 8.7.9 (and tested to confirm: 8.7.8 is not affected as far as we see).

Actions #3

Updated by Felix Nagel about 5 years ago

Same issue here since 8.7.9 when running in Production context (without the stack trace obviously).

I see a lot of breaking changes for EXT:form coming with patch level releases. Please reconsider how fixes are merged in order to prevent things like this in the future.

Actions #4

Updated by Christian Pahren about 5 years ago

I can reproduce this behavior by updating to 8.7.9 from 8.7.8.

Actions #5

Updated by Renzo Bauen about 5 years ago

Christian Pahren wrote:

I can reproduce this behavior by updating to 8.7.9 from 8.7.8.

It does'nt happen the first time you click on "Forms", after unistall and reinstall of EXT:form, but the second time, the error happens.

Actions #6

Updated by Christian Pahren about 5 years ago

Renzo Bauen wrote:

Christian Pahren wrote:

I can reproduce this behavior by updating to 8.7.9 from 8.7.8.

It does'nt happen the first time you click on "Forms", after unistall and reinstall of EXT:form, but the second time, the error happens.

After uninstalling and then reinstalling forms 8.7.9, i may access the Forms Backend Module. Forms are also correctly rendered in frontend context. The error occurs again after refreshing the system cache. However i can not reproduce this behavior safely as it seems to occur erratic.

Actions #7

Updated by Paul Klimek about 5 years ago

Frans Saris wrote:

When running in development context you are not able to open de Web -> Forms module due to a php error:

[...]

Is your form still working in frontend?

I have the same error an my forms in backend and in frontend i can't submit the form.
https://www.pro-webs.de/unternehmen/kontakt/

Actions #8

Updated by Christian Pahren about 5 years ago

The behavior seems to be the result of an configuration error that existed before, but results in an error being thrown since TYPO3 core 8.7.9

Whe had additional form configuration which is included during backend rendering via \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addTypoScriptSetup() but is missing during frontend rendering by not having set plugin.tx_form.settings.yamlConfigurations. (i.e. plugin.tx_form.settings.yamlConfigurations.101 = Ext:foo/bar/baz.yaml)

Providing all configuration files in backend and frontend context has the has fixed the Issue for us.

Actions #9

Updated by Krzysztof Napora about 5 years ago

I'm also using 8.7.9 and I have the same problem .

Actions #10

Updated by Björn Jacob about 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Ralf Zimmermann

Can reproduce. Will provide a fix soon.

Actions #11

Updated by Gerrit Code Review about 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55238

Actions #12

Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55239

Actions #13

Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55240

Actions #14

Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55266

Actions #15

Updated by Ralf Zimmermann about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #16

Updated by Benni Mack over 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF