Bug #83403

<span></span> tag not filled in form extension for type radio

Added by Eckard Gehrke about 2 months ago. Updated 13 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2017-12-20
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hi,
when upgrading from 8.7.8 to 8.7.9 I get the following error:

In 8.7.8 my form was rendered to:

<label class="form-check-label check0">
<input class="xlarge form-check-input" type="radio" name="tx_form_formframework[anfrage][radiobutton-1]" value="Informatik" checked="checked">
<span> Informatik</span>
</label>

whereas in 8.7.9 and current 8.7 branch the result is an empty <span> tag:

<label class="form-check-label check0">
<input class="xlarge form-check-input" type="radio" name="tx_form_formframework[anfrage][radiobutton-1]" value="Informatik" checked="checked">
<span></span>
</label>

I could trace it down to changes in form -> Classes -> Service and ViewHelpers but could not break it down further to a single change. Check0 and counting the radiobuttons in the group is an extension of my own, which still works fine

Best regrads
Eckard.


Related issues

Related to TYPO3 Core - Bug #82210: ext:form multi checkbox values containing . or & result in empty frontend labels Resolved 2017-08-25

Associated revisions

Revision edd210da (diff)
Added by Ralf Zimmermann 13 days ago

[BUGFIX] EXT:form - add compatibility for issue #82210

The fix for issue #82210 implies a breaking change within a minor
release (template changes) and was never documented.

This bugfix adds some compatibility code for integrators who are using
their own templates for RadioButton and/ or MultiCheckbox form elements.

In addition, a deprecation warning is thrown and the corresponding rst
file has been added.

A different patchset adds the appropriate breaking rst file for v9.

Resolves: #83403
Related: #82210
Releases: 8.7
Change-Id: I496886631b4506f2a370cc56473de414d4c3f359
Reviewed-on: https://review.typo3.org/55306
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Tobi Kretschmann <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Eckard Gehrke about 2 months ago

  • Priority changed from Should have to -- undefined --
  • Target version deleted (next-patchlevel)

Hi,

after some more search I found the issue:
If you use own partials RadioButton.html needs to be adopted before you upgrade to 8.7.9
The span tag should now read:

<span>{formvh:translateElementProperty(element: element, property: '{0: \'options\', 1: value}')}</span>

because TranslationService was changed.
Maybe you give some hints on which other own partials should be adopted before the upgrade.

Best regards
Eckard.

PS: Can't set it myelf to resolved.

#2 Updated by Oliver Hader about 2 months ago

  • Priority changed from -- undefined -- to Should have

#3 Updated by Ralf Zimmermann about 1 month ago

  • Related to Bug #82210: ext:form multi checkbox values containing . or & result in empty frontend labels added

#4 Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55306

#5 Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55306

#6 Updated by Gerrit Code Review 17 days ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55306

#7 Updated by Gerrit Code Review 15 days ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55306

#8 Updated by Susanne Moog 15 days ago

  • Target version set to 8.7.10

#9 Updated by Ralf Zimmermann 13 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF