Project

General

Profile

Actions

Bug #84111

closed

CKeditor: custom section / anchor links (external) will result in page=current#section links

Added by Andreas Allacher about 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2018-03-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

When going to RTE and creating a link of type external with the link target "#foo".
Which without baseURL will result in a link to the current page to the section with id="foo".
The generated link is correct. However, the RTE modifies the link to
"t3://page?uid=current#foo"
which results in two issues:
  1. data-rte-error="Page with ID current not found" being added in RTE.
    Actually, I think page ID current should be valid as that is specially handled in TYPO3. Maybe it would even be good to have an option in link browser "current page". That way it will stay the current page when moving the element.
  2. Upon editing the link one cannot modify the section information anymore. However, it is at least visible.

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #78043: Can't create local anchors using RTEClosed2016-09-22

Actions
Actions #1

Updated by Riccardo De Contardi almost 6 years ago

Is this a duplicate of #78043 ?

Actions #2

Updated by Riccardo De Contardi almost 6 years ago

  • Related to Bug #78043: Can't create local anchors using RTE added
Actions #3

Updated by Andreas Allacher over 5 years ago

#78043 was actually with 7.6 and therefore a different RTE, so I am not sure they are the same as this one deals with storage by RTE. Doesn't mean they aren't related though.

Actions #4

Updated by Rene Tobias over 5 years ago

Andreas Allacher wrote:
"Maybe it would even be good to have an option in link browser "current page". That way it will stay the current page when moving the element."

Hello, any update for this? We need it to...

Actions #5

Updated by Susanne Moog over 5 years ago

  • Sprint Focus set to On Location Sprint
Actions #6

Updated by Nicolai Schirawski over 5 years ago

In both TYPO3 8.7.20-dev and 9.5.1-dev, local anchors can be set in two different ways:

- first by choosing "internal link" and selecting a content-Element on the current site
- second by choosing "external link" and typing "#ID" into url-field, where ID is the uid of the content-element.

Both links will be rendered the same in FE:

- either "domain/index.php?id=1#c3" (8 LTS)
- or "domain/#c3" (9 LTS)

Both seem valid and IMHO the ticket can be closed

Actions #7

Updated by Anja Leichsenring over 5 years ago

  • Status changed from New to Resolved
Actions #8

Updated by Benni Mack almost 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF