Bug #84254

BE Login fails after update to 8.7.11 with Firefox

Added by Simon Gilli about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Authentication
Target version:
Start date:
2018-03-14
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Yesterday, there was a message on slack that login fails after updating to 8.7.11. So I tried to reproduce the issue and failed, everthing worked as expected. But today I was not longer able to login again. After clicking to the login button the spinner is turning and turning and no other reaction follows. Clearing browser cache and cookies, restarting the browser or clearing T3's cache at install tool doesn't help. Tested with Firefox 59. Didn't find hints in any of the logs.

Chrome seems not to be affected, login is possible as always. I used version 64 and 65.

Request url: https://sandbox.gilbertsoft.net/typo3/index.php?ajaxID=/ajax/rsa/publickey&skipSessionUpdate=1
Request method: GET

Request headers:
Accept: */*
Accept-Encoding: gzip, deflate, br
Accept-Language: de,en-US;q=0.7,en;q=0.3
Cache-Control: no-cache
Connection: keep-alive
Cookie: be_lastLoginProvider=1433416747; be_typo_user=285ffe5a89e5a15feaade8ed158bb59c; PHPSESSID=usnut8tb5q0n5vf4odr4ad0o5g
Host: sandbox.gilbertsoft.net
Pragma: no-cache
Referer: https://sandbox.gilbertsoft.net/typo3/
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
X-Requested-With: XMLHttpRequest

Response headers:
HTTP/1.1 200 OK
Cache-Control: no-store, no-cache, must-revalidate
Connection: Keep-Alive
Content-Encoding: gzip
Content-Length: 311
Content-Type: text/html; charset=utf-8
Date: Wed, 14 Mar 2018 07:33:29 GMT
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Keep-Alive: timeout=5, max=100
Last-Modified: Wed, 14 Mar 2018 07:33:29 GMT
Pragma: no-cache
Server: Apache/2.4.10 (Debian)
Set-Cookie: be_typo_user=e7748e8b46ddb166b726c5f5fae951ab; path=/; HttpOnly
Vary: Accept-Encoding
X-Frame-Options: SAMEORIGIN
X-JSON: true
X-UA-Compatible: IE=edge


Related issues

Duplicates TYPO3 Core - Bug #84253: BE Login with 8.7.11 and Firefox Quantum Browser Version 59.0 not possible anymore Closed 2018-03-14

History

#1 Updated by Simon Gilli about 2 years ago

  • Related to Bug #84253: BE Login with 8.7.11 and Firefox Quantum Browser Version 59.0 not possible anymore added

#2 Updated by Falk no-lastname-given about 2 years ago

I can confirm this strange behaviour in Firefox 58.0.2 and 59.0. On the same TYPO3 system with the same account a colleague of mine can't login and for me the login works as normal (different client systems and even on a MS Terminal server). We have tested it many times and my colleague is allways affected and I'm not.

#3 Updated by Simon Gilli about 2 years ago

  • Subject changed from Login fails after update to 8.7.11 in Firefox to BE Login fails after update to 8.7.11 with Firefox

#4 Updated by Andreas Fernandez about 2 years ago

  • Status changed from New to Closed

Closed as dupe of #84253

#5 Updated by Markus Klein about 2 years ago

  • Related to deleted (Bug #84253: BE Login with 8.7.11 and Firefox Quantum Browser Version 59.0 not possible anymore)

#6 Updated by Markus Klein about 2 years ago

  • Duplicates Bug #84253: BE Login with 8.7.11 and Firefox Quantum Browser Version 59.0 not possible anymore added

Also available in: Atom PDF