Bug #84253

BE Login with 8.7.11 and Firefox Quantum Browser Version 59.0 not possible anymore

Added by Angelo Previtali over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Authentication
Target version:
-
Start date:
2018-03-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Update March 22nd, 2017

See issue #84503 for a detailed explanation of the Firefox regression

Original report

I installed the new TYPO3 CMS version 8.7.11 and tried to login into the BE with the usual admin access. It do not works anymore with Firefox Quantum Version 59.0!

We tried to clear all Caches in the Install Tool even opcache the the typo3temp/ folder - without any success.
With all other browsers on Windows 10 OS like Chrome (version 65.0.3325.162) or IE 11.251 or EDGE Browser (version 41.16299.248.0) it works without problem!

PHP: 7.1.15
OS: Linux


Related issues

Related to TYPO3 Core - Bug #76120: rsaauth does not submit the name of the submit-buttonRejected2016-05-10

Actions
Related to TYPO3 Core - Bug #84503: Streamline RsaAuth login behaviorRejected2018-03-21

Actions
Has duplicate TYPO3 Core - Bug #84257: BE Login fails after update to 7.6.25 with FirefoxClosed2018-03-14

Actions
Has duplicate TYPO3 Core - Bug #84498: BE login button not working in FirefoxClosed2018-03-20

Actions
Has duplicate TYPO3 Core - Bug #84254: BE Login fails after update to 8.7.11 with FirefoxClosed2018-03-14

Actions
#1

Updated by Simon Gilli over 2 years ago

  • Related to Bug #84254: BE Login fails after update to 8.7.11 with Firefox added
#2

Updated by Andreas Fernandez over 2 years ago

  • Has duplicate Bug #84257: BE Login fails after update to 7.6.25 with Firefox added
#3

Updated by Andreas Fernandez over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Andreas Fernandez
#4

Updated by Gerrit Code Review over 2 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56142

#5

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56143

#6

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56144

#7

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56144

#8

Updated by Oliver Hader over 2 years ago

  • Category set to Authentication
  • Is Regression set to Yes
#9

Updated by Markus Klein over 2 years ago

We fail to reproduce this.

It works for us with FF59 on OSX. Tested with 8.7.9 and 8.7.11

#10

Updated by Markus Klein over 2 years ago

We managed to reproduce. This only happens with this exact sequence:

Username
<TAB>
Password
<TAB>
<ENTER>

Working sequence:

Username
<TAB>
Password
<ENTER>

#11

Updated by Stefan P over 2 years ago

Can confirm, Markus Klein. The password field, once focused, must not lose focus. So, clicking directly on submit will not work as well, one has to press enter.

#12

Updated by Susanne Moog over 2 years ago

Spent some time analyzing the issue and basically what happens is:

Until the next release the proposed workaround is using the sequence posted by Markus:

Username
<TAB>
Password
<ENTER>
#13

Updated by Susanne Moog over 2 years ago

  • Related to Bug #84308: Submit of RSA encrypted form not working with type="image" in TYPO3 8.7.11 added
#14

Updated by Andreas Fernandez over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#15

Updated by Markus Klein over 2 years ago

  • Related to deleted (Bug #84308: Submit of RSA encrypted form not working with type="image" in TYPO3 8.7.11)
#16

Updated by Markus Klein over 2 years ago

  • Related to Bug #76120: rsaauth does not submit the name of the submit-button added
#17

Updated by Gernot Ploiner over 2 years ago

My 2 cents: The problem also appears, when the username and password is saved in firefox. To reproduce this case click into the username field, choose the saved username (the password is filled out automatically) and then click login.

#18

Updated by Stefan P over 2 years ago

Will there be an unscheduled release for this patch? We have lots of customers with this problem.

#19

Updated by Oliver Hader over 2 years ago

Update: Updated release packages are scheduled for Thursday, March 22nd, 2018 to fix these login issues with Firefox which are currently (and unfortunately) causing trouble in TYPO3 v7.6.25 and v8.7.11

#20

Updated by Oliver Hader over 2 years ago

  • Related to Bug #84503: Streamline RsaAuth login behavior added
#21

Updated by Markus Klein over 2 years ago

  • Target version deleted (next-patchlevel)

Patches have been reverted due to regressions, the login shall work again without issues.

#22

Updated by Markus Klein over 2 years ago

  • Has duplicate Bug #84498: BE login button not working in Firefox added
#23

Updated by Markus Klein over 2 years ago

  • Related to deleted (Bug #84254: BE Login fails after update to 8.7.11 with Firefox)
#24

Updated by Markus Klein over 2 years ago

  • Has duplicate Bug #84254: BE Login fails after update to 8.7.11 with Firefox added
#25

Updated by Oliver Hader over 2 years ago

  • Description updated (diff)
#26

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF