Bug #84573

Translated deactivated elements are not displayed in page mode

Added by Sybille Peters over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2018-03-31
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Translated, not activated (hidden) elements are not displayed in page mode. They are visible in list mode, though. Once the elements are activated (unhidden), they are displayed in page mode. Bug seems unrelated to type of element (tested with "Text & Media" and "Bootstrap Carousel").

Reproduce

  1. Create elements, e.g. "Text & Media"
  2. In "page" module, select "Languages", use the "Translate" button (I used translate mode, not copy - don't know if this is relevant)

Screenshots

page mode: 2 translated elements are missing.

list mode: all elements are displayed.

disappeared-elements-in-page-mode.png View (34.9 KB) Sybille Peters, 2018-03-31 22:39

disappeared-elements-n-list-mode.png View (90.6 KB) Sybille Peters, 2018-03-31 22:39

show-hidden.png View (3.71 KB) Sybille Peters, 2018-04-01 09:04

show-hidden2.png View (37 KB) Sybille Peters, 2018-04-01 09:25


Related issues

Related to TYPO3 Core - Bug #84589: "Show hidden content elements" should respect language selection Closed 2018-04-03

Associated revisions

Revision 94acfea0 (diff)
Added by Andreas Fernandez over 1 year ago

[BUGFIX] Only apply language constraints for "Show hidden" checkbox if neccessary

The checkbox "Show hidden content elements" currently checks any selected
language. This is malfunctioning in case the language "Default" is
selected in the "Language" view, as it won't affect any translation.

The patch now changes the handling to add the language constraint only if
the view renders multiple languages and any language is selected, that is
not the default language.

Resolves: #84589
Resolves: #84573
Releases: master, 8.7
Change-Id: I572d594e5828d423e67a40481f44857df79ebae9
Reviewed-on: https://review.typo3.org/56532
Tested-by: TYPO3com <>
Tested-by: Sybille Peters <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Joshua Westerheide <>
Tested-by: Joshua Westerheide <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision 24cec058 (diff)
Added by Andreas Fernandez over 1 year ago

[BUGFIX] Only apply language constraints for "Show hidden" checkbox if neccessary

The checkbox "Show hidden content elements" currently checks any selected
language. This is malfunctioning in case the language "Default" is
selected in the "Language" view, as it won't affect any translation.

The patch now changes the handling to add the language constraint only if
the view renders multiple languages and any language is selected, that is
not the default language.

Resolves: #84589
Resolves: #84573
Releases: master, 8.7
Change-Id: I572d594e5828d423e67a40481f44857df79ebae9
Reviewed-on: https://review.typo3.org/56590
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Sybille Peters over 1 year ago

I just tried to reproduce this and noticed, there is a checkbox on the bottom: "Show hidden content elements"

I might have overlooked that before. So the behaviour does seem correct. It seems like the default behaviour changed now.

#2 Updated by Sybille Peters over 1 year ago

Now the hidden, translated elements are displayed in the "page" module.

But the checkbox "Show hidden content elements" is not displayed anymore so it is not possible to uncheck it.

#3 Updated by Sybille Peters over 1 year ago

  • Description updated (diff)

#4 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56532

#5 Updated by Sybille Peters over 1 year ago

  • Related to Bug #84589: "Show hidden content elements" should respect language selection added

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56532

#7 Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56532

#8 Updated by Andreas Fernandez over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review over 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56590

#10 Updated by Andreas Fernandez over 1 year ago

  • Status changed from Under Review to Resolved

#11 Updated by Sybille Peters over 1 year ago

Update: It was decided in the coredev channel to have "Show hidden elements" checked by default. This should be consistent with the behaviour in previous versions.

#12 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF