Bug #84797

Form editor is not loading

Added by Bjoern Jacob over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Category:
Form Framework
Target version:
-
Start date:
2018-04-19
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On master (and probably on v8) the form editor is not loading at all.


Related issues

Related to TYPO3 Core - Feature #84780: Store icons fetched by the Icon API in localStorage Closed 2018-04-18

Associated revisions

Revision 76ceac62 (diff)
Added by Ralf Zimmermann over 1 year ago

[BUGFIX] Prevent recursive AJAX calls

The form editor calls the icon API within
jQuery's beforeSend() AJAX hook.
Since the Icon API also makes use of AJAX the result is a recursion.
This patch moves the icon requests out of the jQuery AJAX hook.

Resolves: #84797
Releases: master
Change-Id: Ie21806152802774f3f00b3d0320115aa5c0f26e7
Reviewed-on: https://review.typo3.org/56739
Reviewed-by: Björn Jacob <>
Tested-by: Björn Jacob <>
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Ralf Zimmermann over 1 year ago

  • Related to Feature #84780: Store icons fetched by the Icon API in localStorage added

#2 Updated by Ralf Zimmermann over 1 year ago

  • Assignee set to Ralf Zimmermann

#3 Updated by Ralf Zimmermann over 1 year ago

The form editor calls the icon API within jQuery's beforeSend() ajax hook.
Since the icon API also make usage of ajax the result is a recurion.

#4 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56739

#5 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56739

#6 Updated by Ralf Zimmermann over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF