Bug #84844

Additional parameter(record field) needed for processTranslateTo_copyAction function

Added by Ricky Mathew over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Could have
Assignee:
Category:
Localization
Start date:
2018-04-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

processTranslateTo_copyAction is a nice hook for custom translation options.

It will be great to provide a fourth parameter , the 'field' parameter for this function. Because for the localisation of records, we need to know which field is passed to the hook, and then we can decide whether we need to translate that field or not.

It's simple as adding a fourth parameter to the processTranslateTo_copyAction function as follows:

$hookObj->processTranslateTo_copyAction($row[$fN], $langRec, $this, $fN);

Related issues

Related to TYPO3 Core - Feature #67909: Add a hook to DataHandler - localize - translateToMessageClosed2015-07-04

Actions
Related to TYPO3 Core - Epic #88027: Properly handle Hooks/Signals and EventsIn ProgressBenni Mack2019-03-28

Actions
Has duplicate TYPO3 Core - Bug #84845: Additional parameter(record field) needed for processTranslateTo_copyAction functionRejectedBenni Mack2018-04-24

Actions

Also available in: Atom PDF