Bug #84897

Table field name no_search and description in pages properties flatly contradict each other

Added by Sybille Peters about 3 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-04-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

  1. The table.field name `no_search`and description flatly contradict each other: no_search <=> "Include in Search" and green (on) <=> no_search=0. This is unnecessarily confusing. The visual control does fit the text and the number fits the field name, but 0 shouldn't be green (on) when in all other cases 0 is grey (off).
  2. Are these controls in general properly usable for color-blind people? Because if not that would make it hard to use, especially if 1 does not always mean on.

Better might be to change "Include in search" to "Do not include in search" and green to correspond with 1?


Related issues

Related to TYPO3 Core - Bug #84896: Toggle switches is_siteroot, no_search, php_tree_stop for page properties in Behaviour: Miscellaneous not changing value until save is pressedRejected2018-04-30

Actions
Related to TYPO3 Core - Task #84881: The new toggle checkboxes must be adjusted to be accessible for colorblind peopleClosed2018-04-26

Actions
Related to TYPO3 Core - Bug #92678: Inverted BE form checkboxes (TCA flag invertStateDisplay) are spoken incorrectlyClosed2020-10-22

Actions

Also available in: Atom PDF