Bug #85087

Prevent Admin Panel Fluid Debug View from being cached

Added by Marc Hirdes about 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Start date:
2018-05-28
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
adminpanel, fluid, debug, cache
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

we use the APCu cache in TYPO3 8.7.15. When an editor acivates the checkbox "Show fluid debug output" in the preview section of the ADMIN PANEL, this view gets cached. So when another non TYPO3 user visites the page, she or he also gets this view. This should not happen.

Furthermore our editors only need the option to view hidden pages and records, not the fluid debug view. We hide this checkbox via CSS for now.

Kind regards and thanks in advance for help,
Marc


Related issues

Related to TYPO3 Core - Task #84992: Strategy for disabling Fluid debugging in admin panel should be changed Under Review 2018-05-12
Duplicates TYPO3 Core - Bug #86675: "Show Fluid Debug" seems to be cached in regular FE-Cache Closed 2018-10-17

History

#1 Updated by Benni Mack about 1 year ago

  • Target version changed from 8.7.15 to 8.7.19

#2 Updated by Susanne Moog 11 months ago

  • Category changed from Caching to AdminPanel

#3 Updated by Sybille Peters 10 months ago

I can still reproduce this in 8.7.19 with introduction package installation.

No special caching modifications there. Should be reproducible with an out of the box system.

#4 Updated by Sybille Peters 10 months ago

  • Related to Task #84992: Strategy for disabling Fluid debugging in admin panel should be changed added

#5 Updated by Susanne Moog 10 months ago

  • Target version changed from 8.7.19 to Candidate for patchlevel

#6 Updated by Helmut Hummel 3 months ago

  • Duplicates Bug #86675: "Show Fluid Debug" seems to be cached in regular FE-Cache added

#7 Updated by Helmut Hummel 3 months ago

Although this ticket is older than #86675, I'd suggest to close this one here in favor of the latter, as the latter has a fix for TYPO3 9.5 and master attached, that should be backported to 8.7

#8 Updated by Helmut Hummel about 2 months ago

  • Status changed from New to Resolved

#9 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF