Bug #85351

TYPO3 out of sync on translation server

Added by Joerg Kummer about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2018-06-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
translation
Complexity:
Is Regression:
Sprint Focus:

Description

Preconditions
TYPO3 v9

How to reproduce

Find non translated labels on TYPO3 backend.
See for example the labels for "Web -> List" module or inside "About TYPO3" module.
Written in typo3/sysext/core/Resources/Private/Language/locallang_mod_web_list.xlf

Expected result

Translated labels from translation server after updating language packs
or at least l10n/de/core/Resources/Private/Language/de.locallang_mod_web_list.xlf

Actual result
The labels for "Web -> List" module is in English on a user with German language selected.

My observations
Changes for language files in system extensions are not available at translationserver, and can not be translated and downloaded via backend maintenance modul in card for manage language packs. My feeling is, that new labels added in TYPO3 core are never synchronised with the translation server. In addition, I also think, that changes in existing labels are not updated on the translation server either.

The consequences will be, that the coming TYPO3 v9 will miss translations for the new backend modules under "Site Management" and "Admin Tools" and probably several other labels.


Related issues

Related to TYPO3 Core - Bug #81573: Scheduler config check and documentationClosed2017-06-14

Actions
Related to Translation Team - Bug #82174: Missing translation on Core changesResolvedXavier Perseguers2017-08-22

Actions
Related to Translation Team - Bug #86135: [Still] missing translation on core changes v9.xResolvedXavier Perseguers2018-09-04

Actions
#1

Updated by Joerg Kummer about 3 years ago

  • Related to Bug #81573: Scheduler config check and documentation added
#2

Updated by Joerg Kummer about 3 years ago

  • Related to Bug #82174: Missing translation on Core changes added
#3

Updated by Joerg Kummer almost 3 years ago

  • Description updated (diff)
#4

Updated by Xavier Perseguers almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Xavier Perseguers
  • % Done changed from 0 to 30

On it, some projects (new system extensions) were missing for TYPO3 v9, possibly as well network issues for accessing git.typo3.org (but will have to confirm this).

#5

Updated by Xavier Perseguers almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 30 to 100
#6

Updated by Preben Rather Sørensen almost 3 years ago

  • Related to Bug #86135: [Still] missing translation on core changes v9.x added
#7

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF