Bug #81573

Scheduler config check and documentation

Added by Joe Jones 6 months ago. Updated 5 months ago.

Status:
New
Priority:
Must have
Assignee:
-
Category:
CLI
Target version:
Start date:
2017-06-14
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
CLI cron documentation config check
Complexity:
Is Regression:
Sprint Focus:

Description

Dear core developers,

I am working with TYPO3 8.6.1 LTS now and had some problems to build the scheduler cron job. One probnlem is the documentation. The cron parameter changed and "scheduler" is depricated. It was not easy to find the correct parameter. But this works:

.../typo3/sysext/core/bin/typo3 scheduler:run

It would be nice to find this in the scheduler configuration check in the backenend. At the moment there is written erroneously:
Der Befehl, um den Planer von der Kommandozeile auszuf├╝hren lautet: "/.../typo3/sysext/core/bin/typo3 scheduler".

Also in the scheduler check there is a problem with the point "CLI-Skript". Even if the cron jobs works, the config checks alerts a missing cron job. In the point "Last run (Letzte Ausf├╝hrung) there is listet the correct timestamp for the last cron job run. TYPO3 seams to be conencted correcty, but the config check does not notice it.

Thanks
Martin

scheduler-eng-ger.png View (12.1 KB) Wittkiel Gruppe, 2017-06-15 12:42


Related issues

Related to TYPO3 Core - Task #79263: Migrate Scheduler CLI to Symfony Command Closed 2017-01-10
Related to TYPO3 Core - Bug #80868: Use new CLI binary in docs instead of cli_dispatch.phpsh Closed 2017-04-17
Related to Translation Team - Bug #82174: Missing translation on Core changes Accepted 2017-08-22

History

#1 Updated by Wittkiel Gruppe 6 months ago

Same problem here. In german version "run" is missing. Last language-update today.

Operating system: Unix
TYPO3: 8.7.1
PHP: 7.0.18

#2 Updated by Joerg Kummer 5 months ago

  • Related to Task #79263: Migrate Scheduler CLI to Symfony Command added

#3 Updated by Joerg Kummer 5 months ago

  • Related to Bug #80868: Use new CLI binary in docs instead of cli_dispatch.phpsh added

#4 Updated by Joerg Kummer 5 months ago

1. Issue is a missing translation on https://translation.typo3.org/de/TYPO3.core.scheduler/translate/Resources/Private/Language/locallang.xlf#unit=3147843
And this matches all languages/translation. Furthermore the translationserver did not get the change from the core change in april, which should be aktualized first.

#5 Updated by Joerg Kummer 4 months ago

  • Related to Bug #82174: Missing translation on Core changes added

Also available in: Atom PDF