Bug #85731

PageTree does not refresh after enabling/disabling a page via context menu

Added by Anja Leichsenring about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2018-08-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

what happens:

Pages in PageTree do not show / loose the disabled icon if this flag is changed via the context menu in page tree.
Pressing the reload button in page tree header section shows the right icon (or none).

how to reproduce:

drag a new page into the page tree, name it, press enter
Page is now correctly displayed as disabled.
Invoke the context menu, enable the page
context menu vanishes, page still has the same state as before.
refresh the page tree, Icon vanishes.

It is no 100% hit rate, but for me 80% don't refresh the tree.


Related issues

Related to TYPO3 Core - Bug #86096: Activating a page in BE does not update page-treeClosed2018-09-03

Actions
#1

Updated by Tymoteusz Motylewski about 3 years ago

  • Category set to Pagetree
#2

Updated by Riccardo De Contardi over 2 years ago

  • Related to Bug #86096: Activating a page in BE does not update page-tree added
#3

Updated by Riccardo De Contardi over 2 years ago

I report here the description of #86096 to keep track of it:

Hello Core-Team,

I have just checked out current master at cf7917d03bf81b9dbb71f475daee2b483c9feef7

Right-click at a page and choose activate. You will see some refreshments, but page is still disabled visually. Press page-tree update button and page will be displayed correctly.

Right-click at a page and choose activate. You will see some refreshments, but page is still disabled visually. Right-click at another page and activate it, will do some refreshments and my previous activated page will be shown as activated. But current page is still displayed as inactive.

#4

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Closed

I tried several times with both 9.5.14 and 10.4.0-dev and I am not able to reproduce this issue. Each time I used right-click > enable a refresh of the pagetree happens (this happens twice apparently).

Maybe it has been solved in the meanwhile - I am closing it for now.

If you think that this is the wrong decision or experience the issue again, please reopen it or let me know and I'll do.

Also available in: Atom PDF