Bug #85998

Inconsistent URLs in multiple languages

Added by Francois Suter about 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Start date:
2018-08-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I am testing a multiple language site with current TYPO3 master. When building a language-switching menu with the \TYPO3\CMS\Frontend\DataProcessing\LanguageMenuProcessor class I receive inconsistently formed URLs:

Why does the URL in the default language have ?id=1 added to it?

85998-testresult-190124-081508-master.png View (236 KB) Josef Glatz, 2019-01-24 08:16

languagetest85998.zip - Test Extension (2.63 KB) Josef Glatz, 2019-01-24 08:27

History

#1 Updated by Christian Kuhn about 1 year ago

Yes, the link generation is not fully clean, yet. afaik, benni is working on it and a prelimilarily patch has been merged today. https://review.typo3.org/#/c/58022/

#2 Updated by Susanne Moog about 1 year ago

  • Status changed from New to Needs Feedback

Please check if this is fixed with current master. Language handling with sites received a few fixes over the last few days.

#3 Updated by Susanne Moog about 1 year ago

  • Target version changed from 9.4 to 9 LTS

#4 Updated by Benni Mack 12 months ago

  • Target version changed from 9 LTS to Candidate for patchlevel

#5 Updated by Josef Glatz 8 months ago

Can't reproduce it in master10 and 9.5 anymore using the extension added as attachment

#6 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF