Bug #86067

TypoLink generation does not respect language settings

Added by Benjamin Kott almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2018-08-31
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Variant 1: Language Menu Processor

1. Create Site
2. Add Languages
3. Add Page
4. Translate Page
5. View Debug Information in Template for `languagenavigation`

10 = FLUIDTEMPLATE
10 {
    templateName = TEXT
    templateName {
        cObject = TEXT
        cObject {
            data = pagelayout
            required = 1
            case = uppercamelcase
            split {
                token = pagets__
                cObjNum = 1
                1.current = 1
            }
        }
        ifEmpty = Default
    }
    templateRootPaths {
        0 = EXT:extension/Resources/Private/Templates/Page/
    }
    partialRootPaths {
        0 = EXT:extension/Resources/Private/Partials/Page/
    }
    layoutRootPaths {
        0 = EXT:extension/Resources/Private/Layouts/Page/
    }
    dataProcessing {
        10 = TYPO3\CMS\Frontend\DataProcessing\LanguageMenuProcessor
        10 {
            languages = auto
            as = languagenavigation
        }
    }
}

Variant 2: TypoScript Language Menu

1. Create Site
2. Add Languages
3. Add Page
4. Translate Page
5. Render TypoScript Language Menu

page.15 = HMENU
page.15 {
    special = language
    special.value = auto
    wrap = <ul>|</ul>
    1 = TMENU
    1 {
        NO = 1
          NO.linkWrap  = <li>|</li>
    }
}

Variant 3: TypoLink

1. Create Site
2. Add Languages
3. Add Page
4. Translate Page
5. Render Link to current page in different language

page.20 = TEXT
page.20 {
  typolink.parameter.data = page:uid
  typolink.additionalParams = &L=1
}

Related issues

Related to TYPO3 Core - Task #86058: Streamline page language linkingClosed2018-08-31

Actions
Related to TYPO3 Core - Bug #86242: "Hide page in default language" broken for pages without a site configurationClosedDaniel Goerz2018-09-13

Actions
Related to TYPO3 Core - Bug #90613: Add language Parameter to several Link/Uri VHClosed2020-03-02

Actions

Also available in: Atom PDF