Task #86516

Move description field to SEO tab

Added by Marc Hirdes over 1 year ago. Updated about 1 month ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
SEO
Start date:
2018-10-01
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Sprint Focus:

Description

For editors it could be confusing, why the description field is not shown in the SEO tab. Maybe there is a way, if the seo extension is installed, to move the description field to the SEO tab.


Related issues

Related to TYPO3 Core - Task #86515: Show canonical link next to noindex Closed 2018-10-01

Associated revisions

Revision d0c5a1f7 (diff)
Added by Kevin Appelt 2 months ago

[TASK] Move field "description" to SEO tab in page properties

The description field is one of the most important fields
for SEO. When EXT:seo is installed, the description field can
be found on the SEO tab of the page properties. If EXT:seo
is not installed, the field will still be on the Metadata tab.

Resolves: #86516
Releases: master
Change-Id: I9d31f74bcc6e7f0f88a39e718b8437e2f92b30e6
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102
Tested-by: TYPO3com <>
Tested-by: Kevin Appelt <>
Tested-by: Oliver Bartsch <>
Tested-by: Susanne Moog <>
Reviewed-by: Kevin Appelt <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Benni Mack over 1 year ago

  • Target version changed from 9 LTS to Candidate for patchlevel

#2 Updated by Richard Haeser over 1 year ago

When starting the SEO fields and moving them to a separate tab, this was the first thing that was discussed. The issue is that when the EXT:seo is not installed (eg for intranets), you still want the description field to use in internal search methods for example. Without EXT:seo you don't have a SEO tab so you can't place the description field on that tab by default. So this is the reason why it still is on the meta data tab.

Only option is to move the field when EXT:seo is installed. I've done that with the EXT:yoast_seo and you too in EXT:cs_seo. I don't really know if that is a proper solution for core. Need to discuss that with some people.

#3 Updated by Richard Haeser over 1 year ago

  • Tracker changed from Feature to Task
  • TYPO3 Version set to 9

#4 Updated by Richard Haeser over 1 year ago

  • Status changed from New to Accepted

#5 Updated by Richard Haeser over 1 year ago

  • Related to Task #86515: Show canonical link next to noindex added

#6 Updated by Gerrit Code Review 3 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#7 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#8 Updated by Gerrit Code Review 3 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#9 Updated by Gerrit Code Review 3 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#10 Updated by Gerrit Code Review 3 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#11 Updated by Gerrit Code Review 3 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#12 Updated by Gerrit Code Review 3 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#13 Updated by Gerrit Code Review 3 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#14 Updated by Gerrit Code Review 3 months ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#15 Updated by Gerrit Code Review 2 months ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62102

#16 Updated by Kevin Appelt 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#17 Updated by Benni Mack about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF