Bug #86547

doktype field is missing when creating a new page

Added by Sergio Catalá about 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2018-10-02
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

TYPO3 9.5
Fresh new installation.

When you create a new page through the "List" module ("+" icon being used on the right frame, not the drag-and-drop feature in the pagetree) and you select, for example, "Create a new page > Page (inside)", then the properties don't show the "doktype" field.

After saving and re-opening the page properties again, the "doktype" field is shown, but it shows "INVALID VALUE [0]".

This only affects pages created inside of the root page (pid=0).


Related issues

Related to TYPO3 Core - Task #82445: Migrate Page Overlays into Pages table Closed 2017-09-10

Associated revisions

Revision 4e2f110d (diff)
Added by Andreas Fernandez about 1 year ago

[BUGFIX] Omit `overrideVals` in NewRecordController

In the old times of pages_language_overlay, the "New Record" wizard
automatically re-used the doktype of the parent table which was `pages`.
Since pages_language_overlay vanished, the `overrideVals` in the links in
the wizard use the `pages` table.

This results in invalid value for `doktype` if a page in pid=0 is
created, as pid=0 has no doktype.

For this reason, the `overrideVals` parameter is removed.

Resolves: #86547
Related: #82445
Releases: master
Change-Id: I6efa699e5ef09eed6321ae68b5838682214376de
Reviewed-on: https://review.typo3.org/58561
Tested-by: TYPO3com <>
Tested-by: Guido Schmechel <>
Tested-by: Josef Glatz <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>

History

#1 Updated by Mathias Brodala about 1 year ago

  • Description updated (diff)

#2 Updated by Andreas Fernandez about 1 year ago

  • Is Regression set to Yes

#3 Updated by Andreas Fernandez about 1 year ago

  • Related to Task #82445: Migrate Page Overlays into Pages table added

#4 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58561

#5 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58561

#6 Updated by Andreas Fernandez about 1 year ago

  • Target version set to next-patchlevel
  • Complexity set to no-brainer

#7 Updated by Andreas Fernandez about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF