Bug #86597

Incorrect query of the fallback uids in the core

Added by Kay Röseler about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-10-08
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Hello core team,

if only the default language is selected during fallback in the site configuration, the query in the file sysext/core/Classes/Site/Entity/SiteLanguage.php in line 153-155 no longer works because the query

if (!empty($attributes['fallbacks']))

fails because the array Attributes contains

fallbacks => '0'.

Instead, it should be checked for isset here.

Incorrect:

if (!empty($attributes['fallbacks'])) {
    $this->fallbackLanguageIds = is_array($attributes['fallbacks']) ? $attributes['fallbacks'] : explode(',', $attributes['fallbacks']);
}

Correct:

if (isset($attributes['fallbacks'])) {
    $this->fallbackLanguageIds = is_array($attributes['fallbacks']) ? $attributes['fallbacks'] : explode(',', $attributes['fallbacks']);
}
#1

Updated by Josef Glatz about 3 years ago

  • Description updated (diff)
#2

Updated by Josef Glatz about 3 years ago

  • Description updated (diff)
#3

Updated by Georg Ringer about 3 years ago

  • Category changed from Localization to Link Handling, Site Handling & Routing
#4

Updated by Susanne Moog about 3 years ago

  • Sprint Focus set to On Location Sprint
#5

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58698

#6

Updated by Anonymous about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF