Bug #86703

Page's data partly not available via getText if page has form CE

Added by Ben Robinson about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-10-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Some getText-Values are not available in 9.5.0 if there is a form content element (sysext:form) on the site.
How to reproduce:

Set the layout of an empty page to "Layout 2" and render with following TS:

page = PAGE
page{
  bodyTagCObject = TEXT
  bodyTagCObject.value = <body id="page_{field:uid}" class="layout_{field:layout}">
  bodyTagCObject.insertData = 1
  5 = TEXT
  5.value = Test: page_{field:uid} layout_{field:layout}
  5.insertData = 1
  10 =< styles.content.get
}

Result in FE:

[...]
<body id="page_1" class="layout_2">
Test: page_1 layout_2
[...]

Now create a "form" content element on this site.
Result in FE:

[...]
<body id="page_1" class="layout_0">
Test: page_1 layout_2
[...]

The ID is always correct. The layout is correct in page.5 in both cases, but fails in bodyTagCObject.
I had the same issues with backend_layout in bodyTagCObject with form elements.
The same happend when I tried to use htmlTag_stdWrap.
I guess form resets or overrides some vars.

A workaround is to use {page:layout} instead of {field:layout}.


Related issues

Related to TYPO3 Core - Bug #86733: Data in page is invalid if plugin exitsClosed2018-10-24

Actions
Related to TYPO3 Core - Bug #86763: Backend Layout Slide not working in FLUIDTEMPLATE Variables after Upgrade to 9.5.0Closed2018-10-26

Actions
Related to TYPO3 Core - Bug #86979: stdWrap fieldRequired/insertData sometimes not working as expected since TYPO3 9 LTSClosed2018-11-22

Actions
#1

Updated by Tymoteusz Motylewski about 2 years ago

  • Category set to Form Framework
#2

Updated by Georg Ringer about 2 years ago

  • Related to Bug #86733: Data in page is invalid if plugin exits added
#3

Updated by Georg Ringer about 2 years ago

  • Related to Bug #86763: Backend Layout Slide not working in FLUIDTEMPLATE Variables after Upgrade to 9.5.0 added
#4

Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from New to Needs Feedback

I am currently not able to reproduce it with TYPO3 10.0.0-dev (latest master), could you confirm?

Thank you

#5

Updated by Ben Robinson almost 2 years ago

I sorry, I don't have a 10.0.0-dev testing environment. Would it help if i set it up to confirm or has anyone else the possibility to check?

#6

Updated by Riccardo De Contardi almost 2 years ago

Not able to reproduce it on 9.5.4, either

#7

Updated by Ben Robinson almost 2 years ago

I can confirm that: I can not reproduce it on 9.5.4, too. It looks like the issue is solved.
Maybe with Change 58661: https://review.typo3.org/#/c/58661/ ("Avoid overwriting page context in TSFE->cObj by f:cObject") in 9.5.2?

#8

Updated by Riccardo De Contardi almost 2 years ago

@Ben Robinson Thank you for your answer! Do you think that this issue could be closed, or is there still work to do here? Thank you for your reply.

#9

Updated by Ben Robinson almost 2 years ago

@Riccardo De Contardi:
Yes this can be closed, but it would be nice to set a relation to the issue which has resolved this bug. I guess it is https://forge.typo3.org/issues/86979 (Status: resolved).

#10

Updated by Riccardo De Contardi almost 2 years ago

  • Related to Bug #86979: stdWrap fieldRequired/insertData sometimes not working as expected since TYPO3 9 LTS added
#11

Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Needs Feedback to Closed

No problem. Sorry for the delayed reply. Have a nice day and thanks for your answer.

Also available in: Atom PDF