Bug #86763

Backend Layout Slide not working in FLUIDTEMPLATE Variables after Upgrade to 9.5.0

Added by Simon Köhler 10 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-10-26
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I am reading the current backend_layout with a typoscript TEXT object, and pass it to a variable in my FLUIDTEMPLATE like this:

variables{

   beLayout = TEXT
   beLayout.data = levelfield:-1, backend_layout_next_level, slide
   beLayout.override.field = backend_layout
}

In my Fluid-Template I have a s:switch ViewHelper to do some magic. This worked for several years and in the last version of this project with 8.7.19 perfectly.

Now, in TYPO3 9.5.0 the template of the subpage gets selected on the root page. In other words, the sliding mechanism doesn't seem to work anymore.

Any ideas about this?


Related issues

Related to TYPO3 Core - Bug #86733: Data in page is invalid if plugin exits Closed 2018-10-24
Related to TYPO3 Core - Bug #86703: Page's data partly not available via getText if page has form CE Closed 2018-10-20

History

#1 Updated by Michael Stucki 10 months ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Category deleted (Development)
  • TYPO3 Version set to 9

Wrong project.

#2 Updated by Jasmina Ließmann 10 months ago

I can't confirm this issue on the current master (9.5.1-dev) neither with backend layouts created via records in the root page nor with backend layouts created via Page TSconfig.
In both ways the variable in the fluidtemplate gets the value of the backend layout correctly (for 'backend_layout' and 'backend_layout_next_level').

#3 Updated by Alexander Jaschke 10 months ago

I had the same problem with 9.5.0.
I've changed the Typoscript:

belayout = TEXT
belayout.data = levelfield:-2, backend_layout_next_level, slide
belayout.override.data = page:backend_layout

#4 Updated by Georg Ringer 10 months ago

  • Description updated (diff)

#5 Updated by Georg Ringer 10 months ago

  • Related to Bug #86733: Data in page is invalid if plugin exits added

#6 Updated by Georg Ringer 10 months ago

  • Related to Bug #86837: TypoScript Condition: tree.* broken on cached pages added

#7 Updated by Georg Ringer 10 months ago

  • Related to deleted (Bug #86837: TypoScript Condition: tree.* broken on cached pages)

#8 Updated by Georg Ringer 10 months ago

  • Related to Bug #86703: Page's data partly not available via getText if page has form CE added

#9 Updated by Riccardo De Contardi 7 months ago

  • Status changed from New to Needs Feedback

Is this one still reproducible? Could you test it on the latest 9.5.x version? Thank you!

#10 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Simon Köhler)

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or ping me.

Thank you and best regards

Also available in: Atom PDF