Bug #86728

Slug generation wizard fails.

Added by Ricky Mathew about 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-10-24
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:
On Location Sprint

Description

On running "Introduce URL parts ("slugs") to all existing pages" wizard in Upgrade wizard It fails with the following error after a long time:

Fatal error: Uncaught TYPO3\CMS\Core\Error\Http\PageNotFoundException: The requested page does not exist in /typo3_src-9.5.0/typo3/sysext/frontend/Classes/Controller/ErrorController.php:82 Stack trace: #0 /typo3_src-9.5.0/typo3/sysext/frontend/Classes/Middleware/PageResolver.php(108): TYPO3\CMS\Frontend\Controller\ErrorController->pageNotFoundAction(Object(TYPO3\CMS\Core\Http\ServerRequest), 'The requested p...', Array) #1 /typo3_src-9.5.0/typo3/sysext/core/Classes/Http/MiddlewareDispatcher.php(138): TYPO3\CMS\Frontend\Middleware\PageResolver->process(Object(TYPO3\CMS\Core\Http\ServerRequest), Object(class@anonymous)) #2 /typo3_src-9.5.0/typo3/sysext/redirects/Classes/Http/Middleware/RedirectHandler.php(70): class@anonymous->handle(Object(TYPO3\CMS\Core\Http\ServerRequest)) #3 /typo3_src-9.5.0/typo3/sysext/core/Classes/Http/MiddlewareDispatcher. in
/typo3_src-9.5.0/typo3/sysext/frontend/Classes/Controller/ErrorController.php on line 82

The wizard generates slugs for 90% pages , but it misses out the remaining.
I tried to debug the situation ,but couldnt catch the exact control flow of the wizard such that it ends with a pagenotfound error.

History

#1 Updated by Georg Ringer about 1 year ago

  • Assignee deleted (Benni Mack)

#2 Updated by Susanne Moog about 1 year ago

  • Sprint Focus set to On Location Sprint

#3 Updated by Benni Mack 7 months ago

  • Status changed from New to Needs Feedback

Hey Ricky,

we've made some substantial changes in that area until 9.5.5 - can you recheck if you can still reproduce this issue?

Thanks.
Benni.

#4 Updated by Benni Mack 7 months ago

  • Target version changed from next-patchlevel to Candidate for patchlevel

#5 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (Candidate for patchlevel)

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or ping me.

Thank you and best regards

Also available in: Atom PDF