Bug #86807

Some symfony expression condition won't work reliable (in TypoScript)

Added by Sebastian Klein over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2018-10-30
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm currently testing the new symfony expressions inside TypoScript conditions. For that, I used a simple demo pagetree with about 30 pages on 5 levels.

Some conditions did work fine, but I came across several conditions in the last days that did work the first few times and then suddenly did not.

To be more precise, let me show an example:

[17 in tree.rootLineIds]
page.8 = TEXT
page.8.value = <h1>Show some content.</h1>
[end]

What I did:

  • Added a condition like shown above
  • Flushed TYPO3 and PHP Cache
  • Started to open subpages in frontend

The observed behaviour:

  • The demo text is properly rendered on every page where the condition applies.
  • I can reload these pages multiple times, the demo text is still there. So far everything works as expected.
  • As soon as I open a page where the condition does not apply, every already opened page will no longer show the demo text when visiting another time!
  • After that event, all new pages where the condition applies will show the demo text on the first load and then get the text removed on reload.

Tested with both no_cache = 1 and 0.

This issue occurs in both 9.5.0 and 9.5.1.

Can someone confirm this or a similar behaviour?


Related issues

Related to TYPO3 Core - Bug #86837: TypoScript Condition: tree.* broken on cached pages Closed 2018-11-02

History

#1 Updated by Georg Ringer over 1 year ago

  • Related to Bug #86837: TypoScript Condition: tree.* broken on cached pages added

#2 Updated by Frank Naegler over 1 year ago

  • Status changed from New to Needs Feedback

As mentioned in #86837 I cant reproduce this issue.
Can you also please check current master and if it still is an issue for your, please provide more information about your system.

#3 Updated by Sebastian Klein over 1 year ago

This is still an issue in current master. I was also able to reproduce the outlined issue in #86837, too.

I suggest to continue the discussion in #86837.

#4 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to Closed

Hi and sorry for this late reply; I close this issue in favor of #86837; please continue the discussion there.

If you think that this is the wrong decision please reopen it or ping me.

Thank you

#5 Updated by Rene Tobias Tobias about 1 year ago

Any idea when this will be fixed in core?

Also available in: Atom PDF