Bug #86809

Resolve strict type assertion in RecordStateFactory

Added by Oliver Hader about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-10-31
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Applying a strict "string" type to values that are "null" will lead to type errors for TCA properties that are not configured - most probably for "languageField", "transOrigPointerField" or "translationSource".

see https://github.com/georgringer/news/issues/776


Related issues

Related to TYPO3 Core - Bug #86195: Localization of page fails because of SiteNotFoundException Closed 2018-09-07
Related to TYPO3 Core - Bug #86849: Slug generation in record fails since update to 9.5.1 Rejected 2018-11-05
Duplicated by TYPO3 Core - Bug #86821: Slug generator doesn't work for custom records anymore in 9.5.1 Closed 2018-11-01
Duplicated by TYPO3 Core - Bug #87315: TypeError in RecordStateFactory Rejected 2019-01-02

Associated revisions

Revision 3f182270 (diff)
Added by Oliver Hader about 1 year ago

[BUGFIX] Resolve strict type assertion in RecordStateFactory

Applying a strict "string" type to values that are "null" will
lead to type errors for TCA properties that are not configured
- most probably for "languageField", "transOrigPointerField"
or "translationSource".

see https://github.com/georgringer/news/issues/776

Resolves: #86809
Releases: master
Change-Id: I53e9a48f196b8a87c97620346474528a0cf3877e
Reviewed-on: https://review.typo3.org/58807
Tested-by: TYPO3com <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58807

#2 Updated by Oliver Hader about 1 year ago

  • Is Regression set to Yes

#3 Updated by Oliver Hader about 1 year ago

  • Related to Bug #86195: Localization of page fails because of SiteNotFoundException added

#4 Updated by Oliver Hader about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Georg Ringer about 1 year ago

  • Duplicated by Bug #86821: Slug generator doesn't work for custom records anymore in 9.5.1 added

#6 Updated by Joerg Kummer about 1 year ago

  • Related to Bug #86849: Slug generation in record fails since update to 9.5.1 added

#7 Updated by Georg Ringer 11 months ago

  • Duplicated by Bug #87315: TypeError in RecordStateFactory added

#8 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF