Bug #86879

Strange Extbase Variable Dump "Design" on an Whoops, looks like something went wrong. page

Added by Christoph Schwob 8 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-11-07
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Bildschirmfoto 2018-11-07 um 21.18.19.png View (148 KB) Christoph Schwob, 2018-11-07 21:19


Related issues

Related to TYPO3 Core - Feature #86070: Refine DebugExceptionHandler Closed 2018-09-01
Related to TYPO3 Core - Task #86667: adapt font size New 2018-10-16

Associated revisions

Revision ab9f9d63 (diff)
Added by Georg Ringer 7 months ago

[BUGFIX] Add proper scope for styling of DebugExceptionHandler

The styling of the debug output is "namespaced" with `.exception-page`
to avoid influencing other CSS definitions.

Resolves: #86879
Releases: master
Change-Id: I5561b7995826abfd5e1ea53b2b31b30b19c2f208
Reviewed-on: https://review.typo3.org/58870
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Josef Glatz <>
Tested-by: Josef Glatz <>
Tested-by: TYPO3com <>
Reviewed-by: Markus Poerschke <>
Tested-by: Markus Poerschke <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Wouter Wolters 8 months ago

  • Assignee deleted (Andreas Fernandez)

#2 Updated by Georg Ringer 8 months ago

  • Status changed from New to Needs Feedback

thanks for creating the issue!

Is there some custom CSS maybe included?

#3 Updated by Christoph Schwob 8 months ago

Georg Ringer wrote:

thanks for creating the issue!

Is there some custom CSS maybe included?

nope. completely clean v9 instance with a tt_address plugin (this throws the error for the Whoops, looks like something went wrong. page) without any css from this extension.
in the source of the page are are only the inline styles from DebuggerUtility.php and DebugExceptionHandler.php, but no external css files.

(I've also included the TS Template for ext:fluid_styled_content CSS but it's not included in FE on this error page)

#4 Updated by Georg Ringer 8 months ago

  • Status changed from Needs Feedback to New

#5 Updated by Georg Ringer 8 months ago

Cant reproduce that but having an exception stacktrace AND a debug output at the same page is not a good idea and nothing for in production. I would prefer using a debugger like xdebug or if you are using DebuggerUtility or print, then do a die and it looks better.

can be fixed, low prio

#6 Updated by Georg Ringer 8 months ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Could have

#7 Updated by Georg Ringer 8 months ago

#8 Updated by Gerrit Code Review 8 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58870

#9 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58870

#10 Updated by Anja Leichsenring 8 months ago

#11 Updated by Gerrit Code Review 7 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58870

#12 Updated by Georg Ringer 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF