Bug #87089

TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other properties

Added by Josef Glatz over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2018-12-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Problem/Description

A TSConfig setting like

    TCAdefaults {
        pages {
            hidden = 0
        }
    }

must be respected when an editor creates a new page record per drag and drop (like it was in previous TYPO3 versions with the old extJS pagetree).


Related issues

Related to TYPO3 Core - Bug #89211: TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & dropClosed2019-09-19

Actions
Is duplicate of TYPO3 Core - Bug #59383: Create page via drag'n'drop does not respect TCAdefaults from UserTSClosed2014-06-06

Actions
Is duplicate of TYPO3 Core - Bug #82548: TCAdefaults not work on 2 positionsClosed2017-09-24

Actions
#1

Updated by Riccardo De Contardi over 3 years ago

Are those issues related? #59383 #82548

#2

Updated by Josef Glatz over 3 years ago

  • Is duplicate of Bug #59383: Create page via drag'n'drop does not respect TCAdefaults from UserTS added
#3

Updated by Josef Glatz over 3 years ago

  • Is duplicate of Bug #82548: TCAdefaults not work on 2 positions added
#4

Updated by Josef Glatz over 3 years ago

  • Status changed from New to Closed

Closed because of a duplicate

#5

Updated by Claus Harup almost 3 years ago

It is still not possible with drag & drop:

TCAdefaults{
    pages{
        nav_title = testing...
    }
}

.... in TYPO3 v. 9.5.9

#6

Updated by Simon Gilli about 2 years ago

  • Related to Bug #89211: TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & drop added

Also available in: Atom PDF