Bug #82548

TCAdefaults not work on 2 positions

Added by Carsten Hager about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-09-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I create a page by the toolbar above the pagetree (drag-drop)
TCAdefaults.pages.layout = 1 -> work

When I create a page about "Web-> Functions"
TCAdefaults.pages.layout = 1 -> does not work

When I create a page using "Right-click in the Page Tree - New"
TCAdefaults.pages.layout = 1 -> does not work


Files

4TfRoPA9u3.gif (3.03 MB) 4TfRoPA9u3.gif Video Carsten Hager, 2017-10-02 20:32

Related issues

Related to TYPO3 Core - Bug #59383: Create page via drag'n'drop does not respect TCAdefaults from UserTSClosed2014-06-06

Actions
Related to TYPO3 Core - Bug #89211: TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & dropClosed2019-09-19

Actions
Related to TYPO3 Core - Bug #89685: TCAdefaults.pages.backend_layout not working for pages created via drag and dropClosed2019-11-14

Actions
Has duplicate TYPO3 Core - Bug #87089: TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other propertiesClosed2018-12-06

Actions
#1

Updated by Georg Ringer about 4 years ago

  • Status changed from New to Needs Feedback

i can't reproduce in current master and wizard. can you recheck there as well? thx.

#2

Updated by Carsten Hager about 4 years ago

Hey Georg,

with current master 8.7.8 dev, i have the same effect.

See GIF

#3

Updated by Riccardo De Contardi almost 4 years ago

Tested with 8.7.9:

Create a page by the toolbar above the pagetree (drag-drop)> works

Create a page using "Right-click in the Page Tree - New" > works

Create a pate using "List view - New" > works

Create a page with "Web-> Functions" > does not work

#4

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Needs Feedback to New
#5

Updated by Guido Schmechel over 3 years ago

Current master 9.3-dev

Create a page by the toolbar above the pagetree (drag-drop) > does not work
Create a page using "Right-click in the Page Tree - New" > works
Create a pate using "List view - New" > works

Controller/SimpleDataHandlerController.php checks only the TCAdefaults from the beUser

#6

Updated by Stephan grass about 3 years ago

Tested with 9.5:

TCAdefaults.pages.hidden = 0

Create a page by the toolbar above the pagetree (drag-drop)> does not work
Create a page using "Right-click in the Page Tree - New" > works
Create a pate using "List view - New" > works
Create a page with "Web-> Functions" > works

TCAdefaults.pages.cache_tags = TEST

Create a page by the toolbar above the pagetree (drag-drop)> does not work
Create a page using "Right-click in the Page Tree - New" > works
Create a pate using "List view - New" > works
Create a page with "Web-> Functions" > does not work

...

#7

Updated by Riccardo De Contardi about 3 years ago

  • Related to Bug #59383: Create page via drag'n'drop does not respect TCAdefaults from UserTS added
#8

Updated by Josef Glatz almost 3 years ago

  • Has duplicate Bug #87089: TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other properties added
#9

Updated by Simon Gilli about 2 years ago

  • Related to Bug #89211: TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & drop added
#10

Updated by Ben Robinson about 2 years ago

  • Related to Bug #89685: TCAdefaults.pages.backend_layout not working for pages created via drag and drop added
#11

Updated by Riccardo De Contardi almost 2 years ago

I performed the test on 10.4.0-dev (latest master) using the following page TSConfig configuration:

TCAdefaults.pages.hidden = 0
TCAdefaults.pages.no_search = 1
TCAdefaults.pages.cache_tags = TEST
TCAdefaults.pages.backend_layout = 6

these are the results:

  • Create a page by the toolbar above the pagetree (drag-drop)> does not work
  • Create a page using "Right-click in the Page Tree - New" > works
  • Create a pate using "List view - New" > works
  • Create a page using "Right-click in the Page Tree - More options - Create new wizard" > works
  • Create a page using "Right-click in the Page Tree - More options - Create multiple pages" has a mixed behavior:
  • TCAdefaults.pages.hidden = 0 works (maybe because they're not hidden by default); while the others don't work
#12

Updated by Georg Ringer over 1 year ago

  • Status changed from New to Accepted
#13

Updated by Susanne Moog over 1 year ago

  • Status changed from Accepted to Closed

This has the same cause (and solution) as #89211 - closing as duplicate, please continue there.

Also available in: Atom PDF