Bug #89211

TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & drop

Added by Robert Wildling almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Start date:
2019-09-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
TCAdefaults, tsconfig, typoscript
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

As the title already says: the page TSconfig

TCAdefaults.pages.hidden = 0

does not work in TYPO3 9.5.9 and 10.1.0-dev.
(It works fine in TYPO3 8.7.27.)

Confirmed by Simon Gilli via Slack.


Files

Bildschirmfoto 2019-09-22 um 21.14.23.png (61.6 KB) Bildschirmfoto 2019-09-22 um 21.14.23.png Robert Wildling, 2019-09-22 21:18
Screenshot_2019-09-24.png (2.5 KB) Screenshot_2019-09-24.png Page tree drag & drop Simon Gilli, 2019-09-24 16:32

Related issues

Related to TYPO3 Core - Bug #89195: TCAdefaults.pages.hidden = 0 has no effect or is misleadingly documentedClosed2019-09-18

Actions
Related to TYPO3 Core - Bug #88918: Create page via drag'n'drop does not respect TCAdefaults in pagets [from #25021]Closed2019-08-05

Actions
Related to TYPO3 Core - Bug #82548: TCAdefaults not work on 2 positionsClosed2017-09-24

Actions
Related to TYPO3 Core - Bug #89685: TCAdefaults.pages.backend_layout not working for pages created via drag and dropClosed2019-11-14

Actions
Related to TYPO3 Core - Bug #87089: TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other propertiesClosed2018-12-06

Actions
Related to TYPO3 Core - Bug #92146: Page drag and drop doesn't apply TCAdefaults for MM fieldsClosed2020-09-01

Actions
Related to TYPO3 Core - Bug #77847: TCAdefaults imagecols doesn't work in translated recordClosed2016-09-05

Actions
#1

Updated by Simon Gilli almost 3 years ago

  • Category changed from TypoScript to Backend User Interface
  • Status changed from New to Accepted
  • Is Regression set to Yes
#2

Updated by Christian Eßl almost 3 years ago

  • Related to Bug #89195: TCAdefaults.pages.hidden = 0 has no effect or is misleadingly documented added
#3

Updated by Christian Eßl almost 3 years ago

I did some tests in TYPO3 10.1.0:
  • Putting TCAdefaults.pages.hidden = 0 in the User TSConfig
  • Putting TCAdefaults.pages.hidden = 0 in the Page TSConfig

Both times, a newly created page had hidden = 0 set as default value. (as expectd)

Did you doublecheck a few things:
  • Info Module -> Page TSConfig
    You can doublecheck here, that your Page TSConfig is correctly applied.
  • There are several ways to create a new page. The Button "Create a new record" at the top of the list module or by clicking one of the "Create a new page after this page" in the list of pages. I you use the latter, to create a new page right after an existing page, some settings of the existing page (like page type or hidden status) will be applied to the newly created page. In this case, the TCAdefaults settings would be ignored. (which I think is correct)
#4

Updated by Robert Wildling almost 3 years ago

@Christian Eßl: Did you have a chance to do the tests in 9.5, too?

(PageTS config checked [TYPO3 9.5], see screenshot)

#5

Updated by Simon Gilli almost 3 years ago

  • File Screenshot_2019-09-24.png added
#6

Updated by Simon Gilli almost 3 years ago

  • File Screenshot_2019-09-24.png Screenshot_2019-09-24.png added
  • Subject changed from TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev to TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & drop
  • Priority changed from Should have to Must have

Only using the drag & drop functionally of the page tree is affected

#7

Updated by Simon Gilli almost 3 years ago

  • File deleted (Screenshot_2019-09-24.png)
#8

Updated by Simon Gilli almost 3 years ago

  • Related to Bug #88918: Create page via drag'n'drop does not respect TCAdefaults in pagets [from #25021] added
#9

Updated by Simon Gilli almost 3 years ago

  • Related to Bug #82548: TCAdefaults not work on 2 positions added
#10

Updated by Simon Gilli almost 3 years ago

  • Category changed from Backend User Interface to Pagetree
#11

Updated by Robert Wildling almost 3 years ago

The user TsConfig docu has a block with some information about this topic:

https://docs.typo3.org/m/typo3/reference-tsconfig/master/en-us/UserTsconfig/TcaDefaults.html

Excerpt:
```
This example will not work when creating the page from the context menu since this is triggered by the values listed in the ctrl section of typo3/sysext/core/Configuration/TCA/pages.php:

'ctrl' => [
'useColumnsForDefaultValues' => 'doktype,fe_group,hidden',
...
]
```

I assume this is important for this issue? Or does this really only apply to user tsconfig settings, since this information is only available that very part of the documentation?

#12

Updated by Ben Robinson over 2 years ago

  • Related to Bug #89685: TCAdefaults.pages.backend_layout not working for pages created via drag and drop added
#13

Updated by Robin Louis van Komen over 2 years ago

We have the exact same issue.

We just installed a completely clean installation of TYPO3 v9.5.14 via. Composer

It works fine if set in userTsConfig, but pageTsConfig is not respected when creating a new page with drag and drop, which works as expected in TYPO3 v8.x.x

We also tried a clean installation of TYPO3 v10.2.0 via. Composer, but with the exact same outcome as with v9.

We found that in v8.x.x the TCAdefaults seem to come from the following function: createNode in file: sysext/backend/Classes/Tree/Pagetree/Commands.php
But this file does not exists in v9+

Does anyone got any idea?

#14

Updated by Claus Harup over 2 years ago

I have the same issue - how can we push this up the priority list?

#15

Updated by Simon Gilli over 2 years ago

  • Category changed from Pagetree to DataHandler aka TCEmain

After some more investigation I found the corresponding lines to this bug:

https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/core/Classes/DataHandling/DataHandler.php#L679

Here the user settings are applied only in contrast to the behavior of the FormEngine which can be found here:

https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/backend/Classes/Form/FormDataProvider/DatabaseRowInitializeNew.php#L46-L52

So we have currently a big difference if records are created through the FormEngine or directly by the DataHandler.

#16

Updated by Robin Louis van Komen over 2 years ago

Simon Gilli wrote:

After some more investigation I found the corresponding lines to this bug:

https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/core/Classes/DataHandling/DataHandler.php#L679

Here the user settings are applied only in contrast to the behavior of the FormEngine which can be found here:

https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/backend/Classes/Form/FormDataProvider/DatabaseRowInitializeNew.php#L46-L52

So we have currently a big difference if records are created through the FormEngine or directly by the DataHandler.

Yes exactly! The code that handles the pageTS should be done in DataHandler.php, to ensure the same behaviour regardless og the point of entry.

#17

Updated by Robin Louis van Komen over 2 years ago

I just tested in TYPO3 v8.7.31, and it seems like in this version userTSconfig TCAdefaults does not work when creating pages with drag and drop. But pageTSconfig does. This might be the cause of the confusion.

#18

Updated by Simon Gilli over 2 years ago

  • Related to Bug #87089: TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other properties added
#19

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63406

#20

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63406

#21

Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63406

#22

Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63406

#23

Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63406

#24

Updated by Benni Mack over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#25

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed
#26

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Closed to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64278

#27

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64278

#28

Updated by Benni Mack over 2 years ago

  • Status changed from Under Review to Resolved
#29

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed
#30

Updated by Benni Mack over 1 year ago

  • Related to Bug #92146: Page drag and drop doesn't apply TCAdefaults for MM fields added
#31

Updated by Benni Mack over 1 year ago

  • Related to Bug #77847: TCAdefaults imagecols doesn't work in translated record added

Also available in: Atom PDF