Bug #87120

More flexible way to exclude arguments from cHash calculation

Added by Helmut Hummel almost 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-12-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With TYPO3 9.5 a cHash is always appended when generating the final URI that has arguments the are not excluded from cHash.
Setting useCacheHash to 0 in typolink configuration has no effect.

This leads to issues when having array arguments like tx_solr[filters][], which currently cannot be configured to be excluded.

There are multiple option to solve this

  1. Add possibility to use regex to configure includes and excludes from cHash
  2. Always require extensions to provide a white list of arguments they are using that require a cHash
  3. Add possibility to transform array arguments into a URI (like /solr/filter/type:tx_news_domain_model_news/filter/type:pages)

Related issues

Related to TYPO3 Core - Bug #90229: Cast integer to string items during route argument mappingClosed2020-01-28

Actions
Related to TYPO3 Core - Feature #90234: Introduce CacheHashConfiguration and matching indicatorsClosed2020-01-28

Actions
#1

Updated by DANIEL Rémy almost 2 years ago

Hello

The related issue on ext:solr's Github account: https://github.com/TYPO3-Solr/ext-solr/issues/2211

#2

Updated by Marc Bastian Heinrichs almost 2 years ago

It's not only appended, but also required by a request, right?!

Really sad to have no replacement for useCacheHash. Sometimes there is the requirement to have get parameters and the cHash could not be calculated in advance and cacheHash|excludedParameters is no option, because they are too dynamic.

#3

Updated by Oliver Hader 10 months ago

  • Related to Bug #90229: Cast integer to string items during route argument mapping added
#4

Updated by Oliver Hader 8 months ago

  • Related to Feature #90234: Introduce CacheHashConfiguration and matching indicators added
#5

Updated by Benni Mack 8 months ago

Check out https://review.typo3.org/c/Packages/TYPO3.CMS/+/63062 as a feature to overcome this (v10 only unfortunately).

#6

Updated by Helmut Hummel 8 months ago

  • Status changed from New to Closed

Yeah, that is exactly what I meant with "More flexible way to exclude arguments from cHash calculation".
On one hand I think this change deserves a backport to 9.5, as it could be done in a BC compatible way and fixes a quite important shortcoming.
otoh. 10LTS is almost ready to be released, so I'll close this as done

Also available in: Atom PDF