Project

General

Profile

Actions

Bug #87380

closed

AspectFactory::enrich uses 'class_uses' to check for trait, does not work for inherited classes

Added by Wolfgang Klinger about 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-01-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

\TYPO3\CMS\Core\Routing\Aspect\AspectFactory::enrich uses 'class_uses' to check for trait,
but this does not work for inherited classes.

So if someone extends e.g. the PersistedJoinMapper this leads to an exception because $this->siteLanguage is not set.

A better solution would be to check if the property 'siteLanguage' exists in the object.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #97435: Properly deprecate the check for the SiteLanguageAwareTraitClosed2022-04-20

Actions
Actions

Also available in: Atom PDF