Bug #87653

cHash error with extbase plugin and routeEnhancer

Added by Alexander Vogt 5 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-02-05
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I get the following error message after calling a mapped news detail URL: "Request parameters could not be validated (&cHash empty)".

Url generation:

<f:link.action action="show" arguments="{article: record}">text</f:link.action>

Route enhancer:

routeEnhancers:
  newsdetail:
    type: Extbase
    extension: Demo
    plugin: Newsdetail
    routes:
      -
        routePath: '/detail/{news_title}'
        _controller: 'News::show'
        _arguments:
          news_title: article
    defaultController: 'News::show'
    aspects:
      news_title:
        tableName: tx_demo_domain_model_newsarticle
        routeFieldName: slug
        routeValuePrefix: /
    limitToPages:
      - 55

Generated url: /de/news/detail/demo-article-title

How can i solve this? I am currently using the setting "feature.requireCHashArgumentForActionArguments = 0" to avoid this issue.


Related issues

Related to TYPO3 Core - Bug #88136: requireCHashArgumentForActionArguments may cause 404 errors New 2019-04-11

History

#1 Updated by Alexander Vogt 4 months ago

I have solved the issue. The error has occurred due to a "config.defaultGetVars" config.

#2 Updated by Markus Klein 4 months ago

  • Status changed from New to Closed

#3 Updated by Dmitry Dulepov 2 months ago

Same error here but no config.defaultGetVars set. Using only default EXT:news routes straight from docs. If I comment these routes, I see cHash in the url and all works fine. With routes I get a cHash error.

#4 Updated by Dmitry Dulepov 2 months ago

Solution: yes, disable requireCHashArgumentForActionArguments. See why starting from this message: https://typo3.slack.com/archives/C2ZKN8P7G/p1554990363086600

#5 Updated by Dmitry Dulepov 2 months ago

  • Related to Bug #88136: requireCHashArgumentForActionArguments may cause 404 errors added

Also available in: Atom PDF