Bug #87716

space_before_class and space_after_class has an empty value which leads to non-rewritable labels via PageTSConfig

Added by Josef Glatz almost 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-02-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem/Description

From the perspective of an integrator / TYPO3-Admin it's not possible to change a label of a select item where the key (= value of the resulting selectbox in the formEngine) is an empty string with TSConfig.

What is the cause for this issue? The default l10n string for tt_content.space_before_class and tt_content.space_after_class is simply misleading. "None" is the wrong wording. Customers complain about that.

Acceptance Criteria

a) It must be possible to change the affected label with TSConfig.
b) alternatively: the default label or empty key must be changed


Affected TYPO3 Core versions: master, 9.5, 8.7

#1

Updated by Josef Glatz almost 2 years ago

  • Description updated (diff)
#2

Updated by Josef Glatz almost 2 years ago

  • Description updated (diff)
#3

Updated by Wittkiel Gruppe almost 2 years ago

Josef Glatz wrote:

From the perspective of an integrator / TYPO3-Admin it's not possible to change a label of a select item where the key (= value of the resulting selectbox in the formEngine) is an empty string with TSConfig.

Duplicate of #80427? Does this help you https://forge.typo3.org/issues/80427#note-10 ?

#4

Updated by Josef Glatz almost 2 years ago

Wittkiel Gruppe wrote:

Josef Glatz wrote:

From the perspective of an integrator / TYPO3-Admin it's not possible to change a label of a select item where the key (= value of the resulting selectbox in the formEngine) is an empty string with TSConfig.

Duplicate of #80427? Does this help you https://forge.typo3.org/issues/80427#note-10 ?

Hmm. OK,freaky. I will rethink. At least, the default label is misleading for the most of our customers. because in a real world every CE has a visual space before/after

#5

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63528

#6

Updated by Georg Ringer 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF