Bug #87749

content elements with language "all languages -1" not working in default language

Added by Martin Weymayer 3 months ago. Updated 16 days ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2019-02-20
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Steps to reproduce:
- setup 2 languages (de and en f.e.)
- add content element (f.e. text and images) in default language
- set language "all languages 1" to this content element
view page in frontend

Expected result:
- content element with "all language -1" is shown

Actual result:
- no content element is shown in frontend

Only if you switch to second language this content element is shown - but not on page with default language


Related issues

Related to TYPO3 Core - Bug #87757: content elements with language "all languages -1" not working in default language Closed 2019-02-21
Related to TYPO3 Core - Bug #87950: No language fallback Closed 2019-03-19
Duplicates TYPO3 Core - Bug #87093: TYPO3 9.5: CONTENT TypoScript object type does not select records with language set to -1 Closed 2018-12-06

Associated revisions

Revision 0dd23086 (diff)
Added by Benni Mack 2 months ago

[BUGFIX] Include Records with "All Languages" in default language

Records with "All Languages" (sys_language_uid=-1)
aren't shown in TYPO3 v9 anymore of the default
language.

This happened before in TYPO3 v8 and below,
however setting config.sys_language_overlay = 1
triggered the if() condition to jump into the
selection of fetching 0 and -1 records.

As this setting is removed, the check only
applies when overlays are activated, which
is not necessary in language=0.

Resolves: #86972
Resolves: #87749
Resolves: #87093
Releases: master, 9.5
Change-Id: I9308167aede071125df02b848a26283e3f77b759
Reviewed-on: https://review.typo3.org/c/59993
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Susanne Moog <>
Tested-by: Benni Mack <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Benni Mack <>

Revision 4d289472 (diff)
Added by Benni Mack 2 months ago

[BUGFIX] Include Records with "All Languages" in default language

Records with "All Languages" (sys_language_uid=-1)
aren't shown in TYPO3 v9 anymore of the default
language.

This happened before in TYPO3 v8 and below,
however setting config.sys_language_overlay = 1
triggered the if() condition to jump into the
selection of fetching 0 and -1 records.

As this setting is removed, the check only
applies when overlays are activated, which
is not necessary in language=0.

Resolves: #86972
Resolves: #87749
Resolves: #87093
Releases: master, 9.5
Change-Id: I9308167aede071125df02b848a26283e3f77b759
Reviewed-on: https://review.typo3.org/c/60192
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Martin Weymayer 3 months ago

  • Category set to Localization

#2 Updated by Georg Ringer 3 months ago

  • Related to Bug #87757: content elements with language "all languages -1" not working in default language added

#3 Updated by Manfred Egger 3 months ago

  • Duplicates Bug #87093: TYPO3 9.5: CONTENT TypoScript object type does not select records with language set to -1 added

#4 Updated by Martin Weymayer 3 months ago

Is there somebody checking this issue? It is already known since 3 months and solution from https://forge.typo3.org/issues/87093 may work and seems very simple!?

#5 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59993

#6 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59993

#7 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60192

#8 Updated by Benni Mack 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Benni Mack about 2 months ago

  • Related to Bug #87950: No language fallback added

#10 Updated by Benni Mack 16 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF