Project

General

Profile

Actions

Bug #87962

closed

Incorrect cache lifetime for MetaTag Cache

Added by Robert Vock over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
SEO
Target version:
-
Start date:
2019-03-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Sometimes the cache lifetime of meta tags is still not the same as the cache-time of the page.

See the attached Screenshot which shows the cache_pages_tags joined to the cache_pages tables. The page with uid 1 has a cache lifetime of 15 Minutes. Still the html5 metatags are cached longer than the rest of the page. (1 day)

I am not sure how this happened. #86234 introduced the lifetime, but we still sometimes get the error that meta-viewport tag is not available on the page. That's why we decreased the cache lifetime to 15 minutes. But today it happened again and when checking, we noticed that the cache entry for the html5 metatags only was <meta name="generator" content="TYPO3 CMS"> and the viewport metatag was missing.

We set the meta viewport with the following TypoScript:

page.meta.viewport = width=device-width,initial-scale=1

We have USER_INT objects on the page, multiple page-types and additional cache tags (tx_vierwdcanzler_domain_model_project), but as far as I can see those were not responsible for the problem. It's really hard to debug, because it only happens were infrequently and once the cache is cleared, everything works fine.


Files


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #86234: Missing Meta Tags on Pages with *_INT objectsClosedRichard Haeser2018-09-12

Actions
Related to TYPO3 Core - Bug #88165: MetaTags suddenly lostClosed2019-04-17

Actions
Related to TYPO3 Core - Bug #88179: Meta tags and page title are unnecessarily cached in separate cache entriesClosed2019-04-19

Actions
Actions #1

Updated by Robert Vock over 5 years ago

  • Related to Bug #86234: Missing Meta Tags on Pages with *_INT objects added
Actions #2

Updated by Christian Heindl about 5 years ago

  • Priority changed from Should have to Must have
  • Is Regression set to Yes

Seems that we are experiencing the same problem. It also occurs only on very rare occasions.

Actions #3

Updated by Richard Haeser about 5 years ago

  • Related to Bug #88165: MetaTags suddenly lost added
Actions #4

Updated by Helmut Hummel about 5 years ago

  • Related to Bug #88179: Meta tags and page title are unnecessarily cached in separate cache entries added
Actions #5

Updated by Helmut Hummel about 5 years ago

Would be solved with #88179 as this proposes to drop this separate cache entirely

Actions #6

Updated by Richard Haeser almost 5 years ago

  • Status changed from New to Resolved

With the release of TYPO3 v9.5.8, this issue is solved.

Actions #7

Updated by Benni Mack over 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF